eZ430-F2013 Development Tool

User's Guide
Texas Instruments (TI) provides the enclosed Evaluation Module and related material (EVM) to you, the user, (you or user) SUBJED TO the terms and conditions set forth below. By accepting and using the EVM, you are indicating that you have read, understand and agree to be bound by these terms and conditions. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS AND CONDITIONS, YOU MUST RETURN THE EVM AND NOT USE IT.

This EVM is provided to you by TI and is intended for your INTERNAL ENGINEERING DEVELOPMENT OR EVALUATION PURPOSES ONLY. It is provided "AS IS" and "WITH ALL FAULTS." It is not considered by TI to be fit for commercial use. As such, the EVM may be incomplete in terms of required design-, marketing-, and/or manufacturing-related protective considerations, including product safety measures typically found in the end product. As a prototype, the EVM does not fall within the scope of the European Union directive on electromagnetic compatibility and therefore may not meet the technical requirements of the directive.

Should this EVM not meet the specifications indicated in the EVM User’s Guide, it may be returned within 30 days from the date of delivery for a full refund of any amount paid by user for the EVM, which user agrees shall be user’s sole and exclusive remedy. THE FOREGOING WARRANTY IS THE EXCLUSIVE WARRANTY MADE BY TI TO USER, AND IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED, IMPLIED, OR STATUTORY, INCLUDING ANY WARRANTY OF MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE OR NON-INFRINGEMENT.

TI shall have no obligation to defend any claim arising from the EVM, including but not limited to claims that the EVM infringes third party intellectual property. Further, TI shall have no liability to user for any costs, losses or damages resulting from any such claims. User shall indemnify and hold TI harmless against any damages, liabilities or costs resulting from any claim, suit or proceeding arising from user’s handling or use of the EVM, including but not limited to, (i) claims that the EVM infringes a third party’s intellectual property, and (ii) claims arising from the user’s use or handling of the EVM. TI shall have no responsibility to defend any such claim, suit or proceeding.

User assumes all responsibility and liability for proper and safe handling and use of the EVM and the evaluation of the EVM. TI shall have no liability for any costs, losses or damages resulting from the use or handling of the EVM. User acknowledges that the EVM may not be regulatory compliant or agency certified (FCC, UL, CE, etc.). Due to the open construction of the EVM it is the user’s responsibility to take any and all appropriate precautions with regard to electrostatic discharge.

EXCEPT TO THE EXTENT OF THE USER’S INDEMNITY OBLIGATIONS SET FORTH ABOVE, NEITHER PARTY SHALL BE LIABLE TO THE OTHER FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES WHETHER TI IS NOTIFIED OF THE POSSIBILITY OR NOT.

TI currently deals with a variety of customers for products, and therefore our arrangement with the user is not exclusive.

TI assumes no liability for applications assistance, customer product design, software performance, or infringement of patents or services described herein.

User agrees to read the EVM User’s Guide and, specifically, the EVM warnings and Restrictions notice in the EVM User’s Guide prior to handling the EVM and the product. This notice contains important safety information about temperatures and voltages.

It is user’s responsibility to ensure that persons handling the EVM and the product have electronics training and observe good laboratory practice standards.

By providing user with this EVM, product and services, TI is NOT granting user any license in any patent or other intellectual property right.
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI’s standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, trademark right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third-party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation.

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

<table>
<thead>
<tr>
<th>Products</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amplifiers</td>
<td>Audio</td>
</tr>
<tr>
<td>Data Converters</td>
<td>Automotive</td>
</tr>
<tr>
<td>DSP</td>
<td>Broadband</td>
</tr>
<tr>
<td>Interface</td>
<td>Digital Control</td>
</tr>
<tr>
<td>Logic</td>
<td>Military</td>
</tr>
<tr>
<td>Power Mgmt</td>
<td>Optical Networking</td>
</tr>
<tr>
<td>Microcontrollers</td>
<td>Security</td>
</tr>
<tr>
<td></td>
<td>Telephony</td>
</tr>
<tr>
<td></td>
<td>Video &amp; Imaging</td>
</tr>
<tr>
<td></td>
<td>Wireless</td>
</tr>
</tbody>
</table>

Mailing Address: Texas Instruments Post Office Box 655303 Dallas, Texas 75265

Copyright © 2005, Texas Instruments Incorporated
If You Need Assistance

Support for the MSP430 device and the eZ430-F2013 is provided by the Texas Instruments Product Information Center (PIC). Contact information for the PIC can be found on the TI web site at www.ti.com. Additional device-specific information can be found on the MSP430 web site at www.ti.com/msp430 and www.ti.com/ez430.

Note: Kickstart is supported by Texas Instruments

Although Kickstart is a product of IAR, Texas Instruments provides the support for it. Therefore, please do not request support for Kickstart from IAR. Please consult the extensive documentation provided with Kickstart before requesting assistance.

FCC Warning

This equipment is intended for use in a laboratory test environment only. It generates, uses, and can radiate radio frequency energy and has not been tested for compliance with the limits of computing devices pursuant to subpart J of part 15 of FCC rules, which are designed to provide reasonable protection against radio frequency interference. Operation of this equipment in other environments may cause interference with radio communications, in which case the user at his own expense will be required to take whatever measures may be required to correct this interference.
1. Kit Contents, eZ430-F2013

- One eZ430-F2013. The hardware is housed inside a plastic enclosure that may be opened in order to separate the MSP-EZ430D target board from the MSP-EZ430U debugging interface.
- One MSP430 Development Tool CD-ROM which contains several documents including the following related to the eZ430-F2013:
  - MSP430x2xx Family User’s Guide, SLAU144B
  - MSP-FET430 FLASH Emulation Tool User's Guide Errata, SLAZ027
  - eZ430-F2013 User’s Guide (this document)
  - IAR Embedded Workbench (Kickstart Version)

2. eZ430-F2013 Overview

The eZ430-F2013 is a complete MSP430 development tool providing all the hardware and software to evaluate the MSP430F2013 and complete an entire project in a convenient USB stick form factor. The eZ430-F2013 uses the IAR Embedded Workbench Integrated Development Environment (IDE) to provide full emulation with the option of designing a stand-alone system or detaching the removable target board to integrate into an existing design. The USB port provides power to operate the ultra-low-power MSP430 so no external power supply is required.

All 14-pins on the MSP430F2013 are accessible on the MSP-EZ430D target board for easy debugging and interfacing with peripherals. Additionally, one of the digital I/O pins is connected to an LED for visual feedback. The MSP430F2013 includes 16-MIPS performance, a 16-bit Sigma Delta Analog-to-Digital converter, a 16-bit timer, Watchdog timer, brownout detector, a USI module supporting SPI and I²C, and five low power modes drawing as little as 0.5 µA standby.

![eZ430-F2013 Development Tool Diagram](image-url)
3. Software Installation

1. Insert the MSP430 CD-ROM into your computer. It should start automatically, and the MSP430 start page will then be displayed. You can also use a browser to open “index.htm” that is located in the root directory of the MSP430 CD-ROM.

   The eZ430-F2013 is compatible with Windows 2000 and XP.

2. Select Software ➔ IAR Workbench Kickstart and follow the instructions.

3. Respond to the prompts to install the software. The installation procedure will install IAR and TI files. Finish the installation.

   Read the file C:\Program Files\IAR Systems\Embedded Workbench 4.0\430\doc\readme.htm from IAR for the latest information about the Workbench. The term Kickstart is used to refer to the function-limited version of Embedded Workbench including the C-SPY debugger. Kickstart is supplied on the CD-ROM included with each MSP430 tool. The latest version is available from the MSP430 web site at www.ti.com/msp430.

   The above documents are accessible using: Start ➔ Programs ➔ IAR Systems ➔ IAR Embedded Workbench Kickstart for MSP430 V3.

4. Hardware Installation

   1. Connect the eZ430-F2013 to a USB port of your PC.

   2. If the Hardware Wizard starts, respond to the prompts and point the wizard to the drivers located in the following directory on a default installation:

      C:\Program Files\IAR Systems\Embedded Workbench 4.0\430\drivers\TIUSBFET\WinXP

   Two devices will be detected; however, the same directory is used for both devices. Section 11 of the eZ430-F2013 User’s Guide gives detailed instructions on how to install the USB drivers under Windows 2000 and XP.
5. Flashing the LED Demo

This section demonstrates how to setup a project for the eZ430-F2013 and download the application to the MSP430F2013. The sample program will blink the LED on the MSP-EZ430D target board.

Start the Workbench (Start → Programs → IAR Systems → IAR Embedded Workbench Kickstart for MSP430 V3 → IAR Embedded Workbench).

1. Use File → Open Workspace to open the file at C:\Program Files\IAR Systems\Embedded Workbench 4.0\430\FET_examples\Flashing the LED.eww. The workspace window will open.

2. Click the msp430x2xx (C – SpyBiWire) tab at the bottom of the workspace window that corresponds to the eZ430-F2013.

3. Set the correct device by clicking on Projects → Options → General Options → Target and select the MSP430F2013 from the device list.

4. In the Options windows, go to FET Debugger → Setup → Connection → TI USB FET to use the USB Interface.

5. Use Project → Rebuild All to build and link the source code. You can view the source code by double-clicking on the project, and then double-clicking on the displayed source file.

6. Use Project → Debug to start the C-SPY debugger. C-SPY will erase the device Flash, and then download the application object file to the device Flash.

7. Use Debug → Go to start the application. The LED should flash!

8. Use Debug → Stop Debugging to stop debugging, to exit C-SPY and to return to the Workbench.

9. Use File → Exit to exit the Workbench.

Congratulations, you’ve just built and tested your first MSP430 application.
6. Using the MSP430F2013 Target Board & Debugging Interface Independently

The eZ430-F2013 may be used as a stand-alone development board. Additionally, the MSP-EZ430D target board may also be detached from the debugging interface and integrated into another design.

The plastic enclosure can be removed to expose the MSP-EZ430U debugging interface and the MSP-EZ430D target board. The MSP-EZ430D target board is disconnected from the debugging interface by gently pulling the two boards apart.

The target board can be used in a stand-alone design by interfacing to the 14-pins of the MSP430F2013. Holes in the MSP-EZ430D target board provide direct access to each pin of the MSP430F2013. Please refer to the MSP430F2013 Data Sheet for descriptions of each pin’s function.

The MSP-EZ430U debugging interface may also be used as a standard Flash Emulation Tool for all devices in the MSP430F20xx family of microcontrollers. Target boards using other supported MSP430F20xx devices may be designed and flashed using the MSP-EZ430U debugging interface.

7. Where To Go For More Information

The primary sources of MSP430 information are the device-specific data sheets and User’s Guides. The most up to date versions of the User’s Guide documents available at the time of production have been provided on the CD-ROM included with this tool. The most current information is found at www.ti.com/msp430. Information specific to the eZ430-F2013 development tool can be found at www.ti.com/ez430.

MSP430 device User’s Guides and the FET User’s Guide may be accessed from the main page on the CD-ROM under the User’s Guides section. The FET User’s Guide includes detailed information on setting up a project for the MSP430 using IAR.

Documents describing the IAR tools (Workbench/C-SPY, the assembler, the C compiler, the linker, and the librarian) are located in common\doc and 430\doc. The documents are in PDF-format. Supplements to the documents (i.e., the latest information) are available in HTML-format within the same directories. 430\doc\readme_start.htm provides a convenient starting point for navigating the IAR documentation.
8. Frequently Asked Questions

1) **What devices can be programmed with the MSP-EZ430U debugging interface?**
The MSP-EZ430U debugging interface was designed to communicate with devices over a Spy Bi-Wire interface. All members of the MSP430F20xx family of microcontrollers have been tested and are supported.

2) **Does the eZ430-F2013 support fuse blow?**
The MSP-EZ430U debugging interface lacks the JTAG security fuse blow capability. To ensure firmware security on devices going to production, the USB Flash Emulation Tool or the Gang Programmer, which include the fuse blow feature are recommended.

3) **What is the voltage supplied to the MSP-EZ430D target board from the debugging interface?**
The MSP-EZ430U debugging interface supplies a regulated 3.6V to the MSP-EZ430D target board.

4) **Can other programming tools interface to the MSP-EZ430D target board?**
The MSP-EZ430D target board will work with any programming tool supporting the 2-wire Spy Bi-Wire interface. Both the MSP430 USB FET and the Gang Programmer support these devices.

5) **What versions of IAR Embedded Workbench are supported?**
The eZ430-F2013 is supported by IAR Embedded Workbench 3.40A and IAR Embedded Workbench (Kickstart Version) FET_R449 or higher.

6) **What are the part numbers for the connectors between the MSP-EZ430U emulator and the MSP-EZ430D target board?**
   - Header: Mill-Max 850-10-004-20-001000
   - Socket: Mill-Max 851-93-004-20-001000

   Mill-Max: [http://www.mill-max.com](http://www.mill-max.com)

7) **Why does can't the debugger get started (IAR Error: Failed to initialize device)?**
First, check in the Device Manager that the COM Port assigned to the eZ430 does not conflict with port already in use. You may disable the conflicting port or assign a new COM port to the device. Check all devices that use a serial port; even devices that do not show up in the Device Manager.

   Second, check if capacitors C6 or C9 are missing on the MSP-EZ430U debugging interface are populated. These capacitors may have been unknowingly removed while opening the enclosure.
9. eZ430-F2013, Schematic

Figure 2. MSP-EZ430U, Schematic
10. eZ430-F2013, PCB Pictorial

Figure 5. eZ430-2013, PCB Pictorial
11. Detailed Hardware Installation Guide

1. Install IAR Embedded Workbench (Kickstart Version) included on the CD.
2. Insert the eZ430-F2013 into a USB port of your PC.
3. Windows should recognize the new hardware as MSP-FET430UIF JTAG Tool (Figure 6)

![Figure 6. Windows XP Hardware Recognition](image)

4. The “Found New Hardware Wizard” should pop up with a dialog window.
5. Select “Install from a list or specific location [Advanced]” (Figure 7).

![Figure 7. Hardware Wizard](image)
6. Point the Hardware Wizard to the folder containing the MSP-FET430UIF/eZ430-F2013 driver. If you have already installed the IAR Kickstart Edition, the driver will be found at the following default location: `C:\Program Files\IAR Systems\Embedded Workbench 4.0\430\drivers\TIUSBFET\WinXP`.

![Figure 8. Specify driver location](image)

7. The Wizard should find the appropriate driver and on Windows XP system, it will prompt you with a warning that Microsoft did not certify the driver. The drivers have been tested exhaustively and you may ignore this warning and click “Continue Anyway” (Figure 9).

![Figure 9. Windows XP Warning](image)
8. The Wizard will continue to install the driver and notify you that it has finished the installation of the software.

9. After closing the Hardware Wizard, Windows will automatically recognize another new hardware device called the “MSP-FET430UIF – Serial Port”

10. Repeat steps 4 – 8 for the second hardware detection.

11. The eZ430-F2013 is now installed and ready to use. The Device Manager should list a new entry as shown in Figure 10.

![Figure 10. Device Manager](image)