Vivado Design Suite
Tutorial

Embedded Processor Hardware
Design

UG940 (v2016.1) April 6, 2016

(A
ALL F RO('I RAMMABLE.



& XILINX

ALL PROGRAMMAEBLE..

Revision History

The following table shows the revision history for this document.

Date

Version

Changes

04/06/2016

2016.1

Validated with release.

| Send Feedback I



http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=2

& XILINX

ALL PROGRAMMAELE

Table of Contents

REVISION HiSTOIY ceiiiiiiiiiiitiee ettt et e e ettt et e e e e e s s bbb et e e e e e e s s s bebaeeeeeesesasbbbaaaeeeesesanssasbaaeeeesnnannssnaees
Programming and Debugging EMbedded ProCESSOIS ........uiiiiciiiiiiciiieeecciteee ettt ee ettt e e et e e e ette e e e snra e e s entaeeesantaeeeeans
OVEIVIBW ...ttt ettt e e ettt et e e e e ettt e e e e e s e s et e et e eeeeea a bbb e et e e e e e e e nnbe b et e eeseeaaann bbb eeeeeeesasannneneeeeesssanannne
Hardware and SOftWare REQUITEMENTS ........cii ettt e e e e ete e e e e etee e s e aba e e e esabaeeeeabaeesesabeeeeennsens
TULOIIAl DESIGN DS CIIPLIONS . ceiiuttietiiiiee e ieitee ettt e eete e e et e e e et e e e ssabee e e esabeeeessabeeeesssbeeeeeanseeesassbeeesessseeessnnsenesnnssens
LoCating TULOrial DESIGN FIlES .. ..uiiiiiiiee ettt ettt e tee e e et e e e e ettt e e e e e be e e e e eabaee e e nbaeeeeaabeeeseanseeesennseeeeennsens
Lab 1: Building a Zyng-7000 AP SOC ProCeSSOr DESIN.....uuuiiiicuiiieiiiieeeieiiteeeesciteeeessteeeessesteeessssteeeesssseeesssssasesssseeessns
T e Yo [0 4 T o TSRO
Step 1: Start the Vivado IDE and Create @ ProJECE......couciiii ettt s e e e e e s s snaeee s
Step 2: Create an [P INTEErator DESIGN .....uuviiiiiiiiiiteee ettt e ettt e e e e s s sttt e e e e e s s s saabbbeeeeessssssanssnaaeeesssnnas 10
Step 3: USING MARK _DEBUG ......uuuuiiiiiiiiiiiii st s s ss s sannssnsnnnnnnnnnn 17
Step 4: Generate HDL DESIZN FIlES ....ciiuiiiiiiiie ettt et e e e ree e e s ee e e s sabae e e e sabae e e ssnbaeeeenareeas 19
SteP 5: SYNTNESIZE the DESIGN...ccc it e et e e e e et e e e e e bae e e e abee e e e abeeeeeeabaeeeeanbaeeeennrenas 21
Step 6: Insert an ILA Core and Assign Nets 10 DEDUE .......coooiiiiiiciiii e 22
Step 7: Implement Design and Generate BitStrEam.........ccoiciiiiiiciiee e e e et e e e ebae e e e ebae e e e eareeas 26
Step 8: EXPOrt HArdWare 10 SDK .......ciii et ccitee sttt e et e e et e e e et ae e e s sabaee e s sabaeeesnabaeeeesaseeeessnseeesennsenns 27
(6703 ol 11 To T KU USSR 28
1] o I 11T O T OO T OO TR OO PP U PP PPPOTOUPPRRPPPPINN 29
Lab 2: Using SDK and the Vivado IDE LOGIC ANAIYZET ........uviiieeeee ettt ettt e e e e e e e e e e 30
INEFOTUCTION ...ttt ettt e s bt e s bt e e bt e e s abe e s bbeesabe e s baeesabeesabeeesbeesabeeesabeesasaesnseesaseesnns 30
Step 1: Start SDK and Create a Software Application..........occuiiiiiiiii i e 30
Step 2: Run the SOftware APPlICATION .......ooo i e et e e e re e e e e eaba e e e e eabae e e enaraeas 33
Step 3: Connect to the Vivado LOGIC ANAIYZEN .......ueiii it ebee e s e sabae e s areeas 37
(003 ol 11 To T KPS 42
Lab 3: Zyng-7000 AP SOC Cross-TriEI DESISN ...eiiicuurieeiiiiieeeiiee e ettt e e estee e e sste e e e sabee e e e abaeeessbaeeessbeeesssseeesennsenas 43
INEEOTUCTION ...ttt ettt st e e st e s bt e e bt e e sabeesbbeesabeesabaeesabaesabeessbeesabaeesabeesabaesnseesaseennes 43
Step 1: Start the Vivado IDE and Create @ PrOJECT......cccciii ittt e s e e e nareeas 43
Step 2: Create an [P INTEEIrAtOr DESISN ...uuuui s a s s aaaaaanansasnnnnnsnnnnnnnnnnns 44
SEEP 3: SYNTNESIZE DESIZN ..o eeiiiei ettt e et e e e et e e e e st e e e e st ae e e e e baee e e abeeeeenbeeeeennbaeeeennbaaeeenreeas 51
Step 4: Insert an Integrated Logic ANalyzer DEDUE COME....couiiiiiiiiie ettt e e e e e e e 51

Embedded Processor Hardware Design www.xilinx.com l Send Feedback I

UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=3

& XILINX

ALL PROGRAMMABLE.

Step 5: Implement Design and Generate BitStream........ccvivcieeeiiciiee et sbee e e e 57
Step 6: EXPOrt HArdWare 10 SDK.......cii i iciiie e ceitee ettt e et e e e st e e e s sabae e s seabee e e s sabee e e ssabeeeeesabaeesensseeeesnasenns 58
Step 7: Build Application Code iN SDK .......ci ittt e e e tae e e e ebee e e e eatee e e esaraee e esnbaeeeennrenas 59
Step 8: Connect to VIvado LOZIC ANGIYZEN ......viiiiiiie ettt et e e e e e s e e s s sbee e s ssabeeeeenaneeas 66
Step 9: Setting the Processor 10 Fabric Cross TriZEEN.... .. iiii ittt e e e erae e e e ebae e e e 68
Step 10: Setting the Fabric to Processor CroSS-TIIEEN ....uiiiicuiiiiiiieee ittt e esiiee e ssreee e esreeeessreeesssreeesssbeeeesnaseeas 72
(6o 3 ol 1T To T KO PO PTSR 74
12 o TN o =TSRRI 74
Lab 4: Using the Embedded MiCroBlaze PrOCESSON .....uiiicuiiiieiiieee ettt e et e e s tvee e e sttee e s e saree e e eatae e s eabaeeesnseeesenreeas 75
Tl d oo [¥T o1 4T o WSS 75
Step 1: Invoke the Vivado IDE and Create @ ProjeCt......ccueiiciiieiiciiee ettt e e s e e 76
SteP 2: Create an [P INTEEIAtOr DESISN ... i a s aaaasaaaanasaananannnaannnnnes 77
Step 3: Memory-Mapping the Peripherals in IP INt@grator......coocuiiiiiciiii e 92
Step 4: Validate BIOCK DESIEN ...eei ittt ettt e e et e e e et e e e e e abe e e e eeabaee e e abeeeeennbaeeeeanbaeeeeanseneeennrenas 95
Step 5: Generate OULPUL PrOTUCES .....iiiiiiei ettt e ree e e e ebee e s s ee e e st ee e e ssabee e e esabaeeeesnbaeeeennsenas 95
Step 6: Create @ TOP-LeVEl VErilog WIAPPEE ....ui ettt ettt eetee e e e etae e e rae e e e earee e e esabaee e eenbaeeeennreeas 96
Step 7: SYNTRESIZE the AESIZN ..eeiiieiiie e ee e e et ee e e s b ee e e e sbee e e ssabaeeeenareeas 97
Step 8: Insert an Integrated LOgiC ANAlYzZEer (ILA) COTE ...uuiiiiiiii ettt e et etee e e e ebae e e e bae e e e eareeas 97
Step 9: Take the Design through Implementation ..o 104
Step 10: EXporting the DeSIZN 10 SDK.......ooo ittt e et e e e e tte e e e ebte e e s ebteeeeeabaeaeesntaeaesnnes 105
Step 11: Create a “Peripheral Test” APPlCAtioN .......cooccuiiii ittt e e et e e e ebee e e s e aaeeeeeanes 106
Step 12: Executing the Software Application on a KC705 BOard..........cccveeieiiiieiiiieeeiecieeeseciieeessvveeeesveeee e s 110
Step 13: Connect to VIVado LOGIC ANGIYZET ......ooeiiiiee ettt ettt ettt e e ette e e e e tte e e e eateeeeebaeeesesaeeaeeanes 116
Step 14: Setting the MicroBIlaze t0 LOGIC CroSS THIZEN ...uuiiiiciiieieciieeeiectreeeeecteeeessiteeeesstteeesseseeeessssseeesssssaeessnes 119
Step 15: Setting the LOZiC 10 ProcesSOr CroSS-TrSEEN ......uuiiicieeeeeiiieeeeitieeeeeiteeeeeetteeeeectteeeeeesteeeesassaeessasseeaesnnes 123
CONCIUSION 1.ttt ettt e sttt e st e e s bt e e s abeesabeeesabeesabaeeasteesabaeesabeesabeesasbeesabaeenabeesasaesnseesabeesnn 124
16 o 31 11U 125
=T I YL Y ol ST 126
Please Read: IMPortant LEZAl NOTICES .....cccuuiiiieiiie ettt ettt e e te e e e e te e e e e abe e e e enree e s e nbaeeeennsenas 126

Embedded Processor Hardware Design www.xilinx.com l Send Feedback I 4

UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=4

& XILINX

ALL PROGRAMMAELE

Programming and Debugging Embedded Processors

Overview

This tutorial shows how to build a basic Zyng®-7000 All Programmable (AP) SoC processor and a
MicroBlaze™ processor design using the Vivado® Integrated Development Environment (IDE).

In this tutorial, you use the Vivado IP Integrator tool to build a processor design, and then debug the
design with the Xilinx® Software Development Kit (SDK) and the Vivado Integrated Logic Analyzer.

IMPORTANT: The Vivado IP integrator is the replacement for Xilinx Platform Studio (XPS) for embedded
processor designs, including designs targeting Zyng-7000 AP SoC devices and MicroBlaze™ processors.
XPS only supports designs targeting MicroBlaze processors, not Zynq-7000 AP SoC devices.

Hardware and Software Requirements

This tutorial requires that the 2015.4 Vivado Design Suite software (System Edition) release is installed.
See the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973) for a
complete list and description of the system and software requirements.

The following Platform Boards and cables are also needed:
e Xilinx Zyng-7000 AP SoC ZC702 board for Lab 1, Lab 2 and Lab 3
Xilinx Kintex — 7 KC705 board for Lab4
One USB (Type A to Type B)
JTAG platform USB Cable or Digilent Cable

Power cable to the board

Tutorial Design Descriptions

No design files are required for these labs, if step-by-step instructions are followed as outlined.
However, for subsequent iterations of the design or to build the design quickly, TCL files for these labs
are provided. For cross-probing hardware and software, manual interaction with Vivado and Platform
boards is necessary. No TCL files are provided for that purpose.
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Lab 1: Programming a Zynq-7000 AP SoC Processor

Lab 1: Programming a Zyng-7000 AP SoC Processor uses the Zyng-7000 AP SoC Processing Subsystem
(PS) IP, and two peripherals that are instantiated in the Programmable Logic (PL) and connected using
the AXI Interconnect. The Lab uses the following IP in the PL:

e A General Purpose 10 (GPIO)
e A Block Memory
e An AXI BRAM Controller

Lab 1 shows how to graphically build a design in the Vivado IP integrator and use the Designer
Assistance feature to connect the IP to the Zyng-7000 AP SoC PS.

After you construct the design, you mark nets for debugging to enable debug of the logic. Then you
generate the Hardware Design Language (HDL) for the design as well as for the IP. Finally, you
implement the design and generate a bitstream, export the hardware description of the design to the
Software Development Kit (SDK) for software debug.

Design Files
The following design files are included in the zip file for this guide:
e labl.tcl

See Locating Tutorial Design Files.

Lab 2: SDK and Logic Analyzer

Lab 2: Using SDK and the Vivado IDE Logic Analyzer requires that you have the Software Development
Kit (SDK) software installed on your machine.

In Lab 2, you use the SDK software to build and debug the design software, and learn how to connect
to the hardware server (hw_server) application that SDK uses to communicate with the Zyng-7000 AP
SoC processors. Then you perform logic analysis on the design with a connected board.

Lab 3: Zyng-7000 AP SoC Cross Trigger Design

Lab 3: Zyng-7000 AP SoC Cross Trigger Design requires that you have the Software Development Kit
(SDK) software installed on your machine.

In Lab 3, you use the SDK software to build and debug the design software, and learn how to connect
to the hardware server (hw_server) application that SDK uses to communicate with the Zynq-7000 AP
SoC processors. Then, use the cross-trigger feature of the Zyng-7000 AP SoC processor to perform logic
analysis on the design on the target hardware.
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Design Files
The following design files are included in the zip file for this guide:
e lab3.tcl

See Locating Tutorial Design Files.

Lab 4: Programming a MicroBlaze Processor
Lab 4 uses the Xilinx MicroBlaze processor in the Vivado IP integrator to create a design and perform
the same export to SDK, software design, and logic analysis.
Design Files
The following design files are included in the zip file for this guide:
e labd.tcl

See Locating Tutorial Design Files.

Locating Tutorial Design Files

Design data is in the associated Reference Design File.

This document refers to the design data as <Design Files>.
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Lab 1: Building a Zyng-7000 AP SoC Processor Design

Introduction

In this lab you create a Zynq®-7000 AP SoC processor based design and instantiate IP in the processing
logic fabric (PL) to complete your design. Then you mark signals to debug in the Vivado® Logic
Analyzer (Lab 2). Finally, you take the design through implementation, generate a bitstream, and export

the hardware to SDK.

If you are not familiar with the Vivado Integrated Development Environment Vivado (IDE), see the
Vivado Design Suite User Guide: Using the Vivado IDE (UG893).

Step 1: Start the Vivado IDE and Create a Project

1. Start the Vivado IDE by clicking the Vivado desktop icon or by typing vivado at a terminal

command line.

2. From the Quick Start section, click Create New Project, as shown in the figure below:

Quick Start
Af
N

Create New Project

Tasks

Manage IP

Information Center

Documentation and Tutorials

Open Project

Open Hardware Manager

3

Quick Take Videos

E-'

Open Example Project

Kilinx Tcl Store

Release Notes Guide

Embedded Processor Hardware Design
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Figure 1: Vivado Quick Start Page
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The New Project wizard opens.

¢ New Project

=

Create a New Vivado Project

VlVADO‘ This wizard will guide you through the creation of a new project.

To create a Vivado project you will need to provide a name and a location for your project
files. Next, you will specify the type of flow you'll be working with. Finally, you will specify your
project sources and choose a default part.

XILINX

ALL FROGRAMMABLE.

To continue, click Next.

Figure 2: Create New Project Wizard

3. Click Next.

4. In the Project Name dialog box, type a project name and select a location for the project files.
Ensure that the Create project subdirectory check box is checked, and then click Next.

5. In the Project Type dialog box, select RTL Project, and then click Next.

6. Inthe Add Sources dialog box, set the Target language to your desired language, Simulator
language to Mixed, and then click Next.

7. In the Add Existing IP dialog box, click Next.
8. In the Add Constraints dialog box, click Next.
9. In the Default Part dialog box:

10. Select Boards.

11. From the Board Rev drop-down list, select All to view all versions of the supported boards.

CAUTION! Multiple versions of boards are supported in Vivado. Ensure that you are
targeting the design to the right hardware.

12. Choose the version of the ZYNQ-7 ZC702 Evaluation Board that you are using.

13. Review the project summary in the New Project Summary dialog box, and then click Finish to
create the project.
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Step 2: Create an IP Integrator Design

1. In the Flow Navigator> IP Integrator, select Create Block Design.

2. In the Create Block Design dialog box, specify a name for your IP subsystem design or type the
design name zyng design 1. Leave the Directory field set to the default value of <Local to
Project>, and leave the Specify source set field to its default value of Design Sources.

¢ Create Block Design £
Please specify name of block design. ‘
Design name: zyng_design_1
Directory: & <Local to Project> -
Specify source set: 1 Design Sources =

|z| oK l | Cancel

Figure 3: Create Block Design Dialog Box

3. Click OK.
4. 1In the Diagram panel of the Vivado IP integrator window, right-click, and select Add IP.

Alternatively, you can click the Add IP icon in the IP integrator canvas.

This design is empty. Press the ﬁ button to add IF

Figure 4: Add IP Link in IP Integrator Canvas

The IP Catalog opens.
5. Inthe search field, type zynqg to find the ZYNQ7 Processing System IP.
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1P Details *
Search: Zyng (1 match)
- = | Mame: I¥YNQ7Z Processing System

|| version: 5.5 (Rev. 3)
Interfaces: A4, AXI4-Stream
Description: Arm dual core SOC with Zyng fpga

Status: Production

License: Included
Change Log: View Change Lo

Vendor: Hilinx, Inc.
VLNV: xilinx.com:ip:processing_system7:5.5
Repository:  c:/Xilinx/Vivado,/2016.1/data/ip

ENTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 5: The IP Integrator IP Catalog

6. IntheIP Catalog, select the ZYNQ7 Processing System, and press Enter on the keyboard to add it to
your design.

In the Tcl Console, you see the following message:

create bd cell -type ip -vlnv xilinx.com:ip:processing system7:5.5
processing system7 0

There is a corresponding Tcl command for all actions performed in the IP integrator block design.
Those commands are not shown in this document. Instead, Tcl scripts to run each labs are provided.

Note: Tcl commands are documented in the Vivado Design Suite Tcl Command Reference Guide
(UG835).

7. In the IP Integrator window, click the Run Block Automation link.

|L& Designer Assistance available. Run Block Automation

Figure 6: Run Block Automation link

The Run Block Automation dialog box opens, stating that the FIXED IO, and DDR interfaces will be
created for the Zyng-7000 AP SoC core. Also, note that the Apply Board Preset check box is
checked. This is because the selected target board is ZC702.

8. Make sure that both Cross Trigger In and Cross Trigger Out are disabled.
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Lab 1: Building a Zyng-7000 AP SoC Processor Design

¢ Run Block Automation

configuration options on the right.

@, EH] All Automation (1 out of 1 selected)

4k B4
&
=
=
[=]
B
B
TE
]
|
ll:

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its

Description

This option sets the board preset on the Processing System. All current
properties will be overwritten by the board preset. This action cannot be undone.
Zynqg7 block automation applies current board preset and generates external

connections for FIXED_IO, Trigger and DDR interfaces.

MOTE: Apply Board Preset will discard existing IP configuration - please uncheck

this box, if you wish to retain previous configuration.

Instance: /processing_system7_0

Options

Make Interface External: FIXED_IO, DDR
Apply Board Preset:

Cross Trigger In: Disable ~
Cross Trigger Out: Disable -

=

OK

] [ Cancel

Figure 7: Zynq-7 Run Block Automation Dialog Box

9. Click OK.

After running block automation on the Zyng-7000 AP SoC processor, the IP integrator diagram

should look as follows:

processing_system7_0

M_AXI_GPO_ACLK Z Y N Q‘ TTCO_WAVED_OUT

DDR 4= DDR
FIXED_10<k FIXED_IO
USBIND_0<-

M_AXI_GPO<- [}

TTCO_WAVEL OUT
TTCO_WAVEZ OUT
FCLK_CLKD
FCLK_RESETO_M

|

ZYNQ7 Processing System

Figure 8: Zynq-7000 AP SoC Processing System after Running Block Automation
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Now you can add peripherals to the processing logic (PL). To do this, right-click in the IP integrator
diagram, and select Add IP.

10. In the search field, type gpi to find the AXI GPIO IP, and then press Enter to add it to the design.
11. Similarly, add the AXI BRAM Controller.

Your Block Design window should look similar to Figure 9. The relative positions of the IP might
vary.

O TIP: You can zoom in and out in the Diagram Panel using the Zoom In ( % or Ctrl+=) and
Zoom Out ( % or Ctrl+-) tools.

processing_system7_0

DDR <k DDR
FIXED_I0<- ||:BFIXED_I{]
axi_gpio_0 USBIND_0-k

. M_AXI_GPO- [

M_AXI_GPO_ACLK TTCO_WAVED_OUT
ZYNQ TTCO_WAVEL_OUT
TTCO_WAVE2Z_OUT

| S _AXI
s_axi_adk GPIo |||
5 axi_aresetn

AXI GPIO FCLK_CLKD =
axi_bram_ctrl_0 FCLK_RESETO_N /=
.. . |
s 4R S_AXT =
i|bS BRAM_PORTA<- | ZYNQ7 Processing System

s axi_adk
BRAM_PORTB - ||
5 axi_aresetn

AXI BRAM Controller

Figure 9: Block Design after Instantiating IP

Use Designer Assistance

Designer Assistance helps connect the AXI GPIO and AXI BRAM Controller to the Zyng-7000 AP SoC PS.
1. Click Run Connection Automation as shown in Figure 10.

| [§ Designer Assistance available. Run Connection Automation

Figure 10: Run Connection Automation

2. The Run Connection Automation dialog box opens.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 13
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=13

& XILINX

ALL PROGRAMMABLE.
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-

#% Run Connection Automation

NG
=] £F axi_bram_ctrl_o
{I} BRAM_PORTA
{} BRAM_PORTB
i} 5_AXI
| £F axi_gpio_0
-] i GPIO

1k B4

Select connection automation to run and configure its options

R |
Select an automation on the left panel to view its options
’ oK ] ’ Cancel

Figure 11: Run Connection Automation Message

3. Select the All Automation (5 out of 5 selected) check box.
As you select each interface for which connection automation is to be run, the description and
options available for that interface appear in the right pane.

-

#L Run Connection Automation

an interface on the left to display its configuration

| =H{v] All Automation (5 out of 5 selected)

= E| £F axi_bram_ctrl_0
i
{I} BRAM_PORTE
{i 5_aXI
=] £F axi_gpio_0
{} GFIO
{i 5_aXI

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select ‘

LX)

options on the right.

Description
Connect BRAM controller to Block Memory Generator.

Options
Blk_Mem_Gen: New Blk_Mem_Gen

] [ Cancel

Figure 12: Connection Automation Options

4. Ensure the S AXI Interface of the axi bram ctrl 0 has its Clock Connection (for unconnected

clks) field set to the default value of Auto.

This value selects the default clock, FCLK
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#- Run Connection Automation | 23 |
Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its
configuration options on the right. ‘
Q| =] All Automation (5 out of 5 selected) Description
= =+ £F axi_bram_ctrl_0 ) )
- 7] [} BRAM_PORTA Connect Slave interface (/axi_bram_ctrl_0/S_AXI) to a selected Master address space.
=51 H
[¥] {1 BRAM_PORTE Options
Al s~ | _
E| 7] £ axi_gpio_0 Master: /processing_system7_0/M_AXI_GP0
Clock Connection (for unconnected clks) : | Auto v
[ oK ] [ Cancel

Figure 13: S_AXI Connection Automation Options for axi_bram_ctrl_0

¢ Run Connection Automation @

Automatically make connections in your design by checking the boxes of the interfaces to connect.
Select an interface on the left to display its configuration options on the right. ‘

Q| =H¥] Al Automation (5 out of 5 selected)
e = El .ﬂ axi_bram_ctrl_0
{I} ERAM_PORTA

g
/| I} BRAM_PORTB Interface: faxi_gpio_0/GPID

Description

Connect Board Part Interface to IP interface.

=

lmr S_AXI
El . iF axi_gpio_0 Options
. o E Select Board Part Interface: | gpio_sw -

----- ~{v] @ s_AxI

DK H Cancel ]

Figure 14: Run Connection Automation Dialog Box for GPIO Interface of axi_gpio_0

5. Forthe s AXT interface of axi gpio 0 instance, leave the Clock Connection (for unconnected
clks) field to Auto.
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-

é\t Run Connection Automation S

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its
configuration options on the right. ‘
Q, E}- All Automation (5 out of 5 selected) Description
=1 V] LF axi_bram_ctrl_0
:‘ I} BRAM_PORTA Connect Slave interface (/axi_gpio_0/S_AXI) to a selected Master address space.
(<] -
1 {I} BRAM_PORTB Options

@ s_ax1

E' £ axi_gpio_0 Master: /processing_system7_0/M_AXI_GP0

Clock Connection (for unconnected clks) : | Auto v
OK ] [ Cancel
Figure 15: S_AXI Interface Options for axi_gpio_0
6. Click OK.

The IP integrator subsystem looks like Figure 16. The relative positions of the IP might differ slightly.

Diagram = 5 =
# & zynq_design_1 »
o
e Lo teds_avits
"O.: ax_gpio_D processing_system?_0
= DDR <
[ o FIED_IO<- % E[[;réa 10
H " g
- "j”"::m e USBIND_0dF
W I i i S o
[ AXT GPIO IGPO_ACLK TTC0_WAVED_OUT-
) AXI GP1
a, ZYNQ. TTCO_WAVEL OUT-
o TTCO_WAVE2 OUTf-
B FOLK_CLkDf——
=] axi_bram_ctd_0 FOLK_RESETO_Np—p
=
i s axt ZYNG? Processing System t_process tem7_0_50M ) o
& 1 ;-’“:d‘ BRAM_PORTAC: YNQ7 Processing Syster rst_p ing_system7 0_ processing_ system3._D_axi. peiph
- &RaM_PORTES [[j=— est_sync_clk mib_reset - o
) o et in bus,_ struct_reset{0:0] fu 11| s00_axt
E 'AXT BRAM Controller [ — peripheral_reset{0:0] . ——{ACIK
3 —mb_debug_sys_rst t aresetn[0:0] ARESETN
4 axi_bram_ctrl_0_bram —jdem_locked peripheral_aresetnll: 0] p—p R v LR »
ﬁ S00_ARESETN &= = =T
[||<cBRAM_PORTA Processor System Reset MOO_ACLK MOL_AXT= fid
& [[|=BraM_pORTE p——H00_ EoE
MOO_ARESETH
&l Block Memary Generator MOL_ACLK
P MO1_ARESETN
AXI Interconnect
o I 0L

Figure 16: Zynq-7000 AP SoC Processor System

7. Click the Address Editor tab and expand the processing system7 0 hierarchy to show the
memory map of all the IP in the design.

In this case, there are two IP: the AXI GPIO and the AXI BRAM Controller. The IP integrator assigns
the memory maps for these IP automatically. You can change them if necessary.
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8. Change the range of the AXI BRAM Controller to 64K, as shown below.

&= Diagram X | & Address Editor x
X cell

A

2 [=h4F processing_system7_0
EI'B Data (32 address bits : 0x40000000 [ 1G ])
=m gxi_gpio_0

F

m | ¢

- axi_bram_ctrl_0

Slave Interface Base Name Offset Address

5_AXI REE Ox4120_0000

Range

64K

8K

16K |_|

High Address

v 0x4l20_FFFF

8K . 0x4000_1FFF

.

Figure 17: Change Range of axi_bram_ctrl to 64K

9. Click the Diagram tab to go back to the block design.

10. Click the Regenerate Layout button | #" to regenerate an optimal layout of the block design.

Step 3: Using MARK_DEBUG

You now add hooks in the design to debug nets of interest.

1. To debug the master/slave interface between the AXI Interconnect IP

(processing system7 0 axi periph)and the GPIO core (axi_gpio_0), in the Diagram view,

select the interface, then right-click and select Mark Debug.

In the Block Design canvas on the net that you selected in the previous step, a small bug icon
appears, indicating that the net has been marked for debug. You can also see this in the Design

Hierarchy view, as displayed in Figure 18, on the interface that you chose to mark for debug.

Embedded Processor Hardware Design
UG940 (v2016.1) April 6, 2016

www.xilinx.com

| Send Feedback l

17


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=17

& XILINX

ALL PROGRAMMABLE, Lab 1: Building a Zyng-7000 AP SoC Processor Design

Design — 0O 1 X
Q X |E =

;’g. zyng_design_1 axi_gpio_0
-5 External Interfaces g system?_0_axi_periph o
=+ Interface Connections
axi_bram_ctrl_0_BRAM_PORTA a
axi_bram_ctrl_0_BRAM_PORTE
axi_gpio_0_GPIO

“|4ks_Axt
&_axi_aclk GPIO 4
_axi_aresetn

AXI GPIO

# ¢ HsyE nT axi_bram_ctrl 0
processing_system7_0_axi_periph_M01_AXI SETN D%D e -
processing_system7_0_DDR K m MOLAXI S B 55{#5-_*” BRAM_PORTAE [||=
processing_systemy_0_FIXED_IO SETH "'m.'x'k BRAM_PORTBAF |—
-2+ progessing_system7_0_M_AXI GP) K '—‘5-“’“-3' HREE
HHE Nets SETN AXI BRAM Controller

H-4F axi_bram_ctrl_0 (AXI BRAM Controller:4.0)
+-4F axi_bram_ctrl_0_bram (Block Memory Generator:8.2)

=

=

: (I Interconnect
[H4F axi_gpio_0 (AXI GPID:2.0)

=

=

=

+-4F processing_system7_0 (ZYNQ7 Processing System:5.5)
+-{# processing_system7_0_axi_periph
+1-4F rst_processing_system7_0_50M (Frocessor System Reset:5.0)

Figure 18: Design Hierarchy: Icon for Mark Debug

2. From the toolbar, run Design-Rules-Check (DRC) by clicking the Validate Design button _ ]
Alternatively, you can do the same from the menu by:

o Selecting Tools > Validate Design from the menu.
o Right-clicking in the Diagram window and selecting Validate Design.

The Validate Design dialog box opens to notify you that there are no errors or critical warnings in
the design.

The Tcl console shows the following warning.

WARNING: [BD 41-1634] Updates have been made to one or more nets marked for
debug. It is required to open the synthesized design and use the Set Up Debug
wizard to insert, modify or delete Debug Cores. Failure to do so could result in
critical warnings and errors in the implementation flow.

This warning message informs you that you must insert a debug core after synthesizing the design.
Likewise, after the debug activities have been done and the nets have been “unmarked” for debug,
then you must delete any existing debug cores from the synthesized netlist.

3. Click OK.
4. From the Vivado menu, save the block design by selecting File > Save Block Design.

Alternatively, you can press Ctrl + S to save your block design or click the Save button in the
Vivado toolbar.
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Step 4: Generate HDL Design Files

You now generate the HDL files for the design.

1. Inthe Sources window, right-click the top-level subsystem design and select Generate Output
Products.

This generates the source files for the IP used in the block design and the relevant constraints file.
You can also click Generate Block Design in the Flow Navigator to generate the output products.
The Generate Output Products dialog box opens, as shown in Figure 19.

2. Leave all the settings to their default values. Click Generate.

¢ Generate Output Products £

The following output products will be generated.

Preview

Q4 zyng_design_1.bd (Global)

= -l Synthesis
[ ]
e # I Implementation
= H
=i Simulation

Synthesis Options
@) Global
Out of context per IP
Out of context per Block Design
Run Settings

Mumber of jobs: 4 -

l;?l Apply Generate l | Cancel

Figure 19: Generate Output Products Dialog Box

3. The Generate Output Products dialog box opens after the output products are generated.

4. Click OK.

5. In the Sources window, right-click the top-level subsystem, zynq_design_1, and select Create HDL
Wrapper to create an top level HDL file that instantiates the block design.

The Create HDL Wrapper dialog box presents you with two options:

e The first option is to copy the wrapper to allow edits to the generated HDL file.
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The second option is to create a read-only wrapper file, which will be automatically generated

-

¢ Create HDL Wrapper

wiould like to modify this file.

Options

You can either add or copy the HDL wrapper file to the project. Use copy option if you ‘

(") Copy generated wrapper to allow user edits

(@) Let Vivado manage wrapper and auto-update

=

0K l ’ Cancel

Figure 20: Create HDL Wrapper Dialog Box

6. Select the default option of Let Vivado manage wrapper and auto-update

7. Click OK.
After the wrapper has been created, the Sources window looks as follows.
Sources — 0O a1 X
L il 2--1

Embedded Processor Hardware Design

[ZH Design Sources (1)
- zynq_design_1_wrapper (zynq_design_1_wrapper.v) (1)

=, zyng_design_1_i - zyng_design_1 (zyng_design_1.bd) (1)
: [H-# zyng_design_1 (zynq_design_1.v) (7)

-- | Constraints

[+ Simulation Sources (1)

Hierarchy | IP Sources | Libraries | Compile Order

Figure 21: Source Window After Creating the Wrapper

www.xilinx.com

UG940 (v2016.1) April 6, 2016

| Send Feedback I

20


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=20

& XILINX

ALL PROGRAMMABLE, Lab 1: Building a Zyng-7000 AP SoC Processor Design

Step 5: Synthesize the Design

1. After generating the IP Integrator design, in the Flow Navigator, click Run Synthesis.
Note: Running synthesis could take several minutes.

When synthesis completes, the Synthesis Completed dialog box opens.

Synthesis Completed 5

[0] Synthesis successfully completed.

Next
Run Implementation

@) Open Synthesized Design
View Reports

Don't show this dialog again

oK ] | Cancel

Figure 22: Synthesis Completed Dialog Box

2. Select the Open Synthesized Design option, and click OK.
Vivado opens the synthesized design.

The Debug window opens as you open the synthesized design. You can open this window manually
by selecting Window > Debug, or by choosing the Debug window layout.

The Debug window displays a list of nets in the Unassigned Debug Nets folder, as shown in
Figure 23. These nets correspond to the various signals that make up the interface connection that
you marked for debug in the IP block design.
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Debug
A Mame Driver Cell
=
= =} Unassigned Debug Nets (100)
= =HFi zyng_design_1_i/processing_system7_0_axi_periph_M00_AXI_ARADDR (2) LUT®
i zyng_design_1_i/processing_system7_0_axi_periph_M00_AXIT ARADDR[0O] LUTE
P i zyng_design_1_ifprocessing_system7_0_axi_periph_M00_AXIT ARADDR[1] LUT®
= i zyng_design_1_i/processing_system7_0_axi_periph_M00_AXIT ARADDR[2] LUTE
j i zyng_design_1_ifprocessing_system7_0_axi_periph_M00_AXIT ARADDR[3] LUT®
3 i zyng_design_1_i/processing_system7_0_axi_periph_M00_AXIT ARADDR[4] LUTE

. o~ T4 zynq_design_1_i/processing_system7_0_axi_periph_M00_AXI ARADDR[5] LUT®
= o~ T4k zynq_design_1_i/processing_system7_0_axi_periph_M00_AXI_ARADDR[E] LUTE

P [8% mmpmn Aacian 1 ifmrncsccina mecbamn T N =i meeinbk BAOD AT ADARLGDIT] 11ITA
Debug Cores | Debug Nets
5 Tcl Console | © Messages | [ Log | 21 Reports | 3» Design Runs-, ¥ Debug

Figure 23: Unassigned Debug Nets Folder

Step 6: Insert an ILA Core and Assign Nets to Debug

1. On the left-hand toolbar of the Debug window, click the Set up Debug button

2. When the Set up Debug wizard opens, click Next.

-

#- Set Up Debug

=

Set Up Debug

Vl\/ADO‘ This wizard will guide you through the process of

1. Choosing nets and connecting them to debug cores.

2. Associating a clock domain with each of the nets chosen for debug.

3. Choosing additional features on the debug cores like Data Depth, Advanced Trigger
mode and Capture Control.

Note: This setup wizard does not apply to the VIO, IBERT or JTAG-to-AXI-Master debug
cores. Please refer to Vivado Design Suite User Guide: Programming and Debugging
{UG908) for further instructions on how to use these IPs.

XILINX

ALL PROGRAMMABLE.

To continue, click Mext

Figure 24: Set Up Debug Wizard
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On the second panel of the wizard, notice that some of the nets in the table do not belong to a

Lab 1: Building a Zyng-7000 AP SoC Processor Design

clock domain. These nets are highlighted below in Figure 25.

Nets

#- Set Up Debug

to Debug

= | [+ d7i3 zyng_ demgn 1 u’prucessmg system7_0_.
B |-

zyndesu]nl|fprucessmq_system? 0.

nq_design_1_ifprocessing_system7_0_.
}JJ"ﬂ zynq_design_1_i/processing_system7_0_.

Find Nets to Add... |

stem7_0_...

zyng_design_1_ifprocessing_system7_0_...

Hh Ik zynq_de5|gn_1_|fpr0cessmg_system?_ﬂ_

- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...
- i zynq_design_1_ifprocessing_system7_0_...

@ sSome net(s) do not have a clock domain. more info

D\ Name

Clock Domain

.. zyng_design_1...
ng_design_1...

zynq_design_l...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...
zyng_design_1...

Driver Cell TRIG DA...
v

LUTE

LUTE
LuT2
LUTE
LuT2
LUT3
FDRE
LUTS
FDRE
LUTE
LUT4

< Back ” Next =

The nets below will be debugged with ILA cores. To add nets click "Find Nets to Add". You can also '
select nets in the Metlist or other windows, then drag them to the list or click "Add Selected Mets".

LLLLLLLLLCLLKL

=]

v
v
v
v
v
v
v
v
v
v
v
v
Nets to debug: 100

Figure 25: Set Up Debug

IMPORTANT: All signals captured by a single ILA core must have the same clock domain

selection.

3. Click the Filter button in the left toolbar to show only the nets that do not have a clock domain
associated with them.

Embedded Processor Hardware Design

UG940 (v2016.1) April 6, 2016

www.xilinx.com

| Send Feedback l

23


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=23

& XILINX

ALL PROGRAMMABLE..

4. Select all the nets that are shown in the dialog box after filtering, then right-click on your selection

Lab 1: Building a Zyng-7000 AP SoC Processor Design

and select Select Clock Domain.

[, stuppebs ==

Nets to Debug
The nets below will be debugged with ILA cores. To add nets click "Find Mets to Add". You can also select ‘
nets in the Metlist or other windows, then drag them to the list or click "Add Selected Mets".

|o Some net(s) do not have a clock domain. more info

Q\ Name

2]

| Find Nets to Add...

Clock Domain

oo (] zyng_design_1_i/processing_system7_0_...
processing_system7_0_axi_periph_MD...

_0_axi_periph_MO...

Set Probe Type

Export to Spreadsheet...

_system7_0_axi_periph_M0...
system7_0_axi_periph_M0...
_system7_0_axi_periph_M0...
stem7_0_axi_periph_M0...

Driver Cell Probe Type

ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger
ata and Trigger -

| »

1

Mets to debug: 146

Lz ]

<Back | Next> | Fnish | | cancel

5. In the Select Clock Domain window, make sure that the selected filter is GLOBAL_CLOCK, and the

Figure 26: Set Up Debug: Select Clock Domain

Search hierarchically check box is checked.

6. Selectthe zyng design 1 i/processing system7 0/inst/FCLK_CLKO net as the clock

domain.

Embedded Processor Hardware Design

UG940 (v2016.1) April 6, 2016

www.xilinx.com

l Send Feedback l

24


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=24

& XILINX

ALL PROGRAMMABLE, Lab 1: Building a Zyng-7000 AP SoC Processor Design

-

¢ Select Clock Domain

=

The list below is 'GLOBAL_CLOCK' type of clock net.
If you want to see the list of different type of clock net(s), please change the ‘
combaobox selection.

O, I = | GLOBAL_CLOCK ¥ |[¥/] Sgarch hierarchically

zyng_design_1_i/processing_system?_0/inst/FCLK_CLKD

Figure 27: Select Clock Domain Option

7. Click OK.

The Specify Nets to Debug dialog box updates with the assigned clock domains.
8. Click Next.

In the Set up Debug dialog box, click Next to open the ILA General Options page.

-

#- Set Up Debug
ILA (Integrated Logic Analyzer) General Options

e

Sample of Data Depth | 1024 hd
Input Fipe Stages 0 v
Trigger and Storage Settings
Capture Control
Advanced Trigger

[ < Back ” Next = ] Finish

Figure 28: Setting Trigger and Capture Modes

9. Select both the Capture Control and Advanced Trigger check boxes.
10. Click Next.

The Set up Debug Summary page opens.
11. Verify all the information and click Finish.

Note: It takes some time for Vivado to add the ILA and Debug Hub cores as black boxes into the
synthesized design. During this time, you see several Tcl commands executing in the Tcl Console.
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Step 7: Implement Design and Generate Bitstream

1.

6.

In Flow Navigator > Program and Debug, click Generate Bitstream to implement the design and
generate a BIT file.

The Save Project dialog box opens.
Click Save.

The Out of Date Design dialog box opens informing you that saving the new debug related
constraints could make your synthesis out of date.

Click OK.
The No Implementation Results Available dialog box opens.
Click Yes.

Notice that you can view the progress of the flow in the upper right-hand corner of the interface, as
shown below.

Running route_design

Figure 29: Status Indicator

After the bitstream generates, the Bitstream Generation Completed dialog box opens. In it, select
Open Implemented Design.

Bitstream Generation Completed £

|:6:| Bitstream Generation successfully completed.
Ne;t
@) Open Implemented Design
View Reports

Open Hardware Manager

Generate Memory Configuration File

Don't show this dialog again

oK I | Cancel

Figure 30: Bitstream Generation Completed

Click OK.
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The Vivado dialog box prompts you to close the synthesized design before opening the
implemented design.

You can keep the synthesized design open if you want to debug more signals; otherwise close the
synthesized design to save memory.

7. In the implemented design, go to the Netlist window, as displayed in Figure 31, to see the inserted
ILA and Debug Hub (dbg hub) cores in the design ().

Metlist — O
= T |[E

+1 zyng_design_1_wrapper

+H-= Nets (261)

+5 Leaf Cells (4)

+{@ dbg_hub (dbg_hub_CV)
+{3] u_ila_0 (u_ila_0_cV)
+HI] zyng_design_1_i (zynq_design_1]

o]
><:

Figure 31: Implemented Design

8. When the implemented design opens, look at the timing window to ensure that all timing
constraints were met.

Step 8: Export Hardware to SDK

In this step, you export the hardware description to SDK. You will use this hardware description in Lab 2:
SDK and Logic Analyzer.

IMPORTANT: fFor the Digilent driver to install, you must power on and connect the board to the host PC
before launching SDK.

1. From the main Vivado File menu, select File > Export > Export Hardware.
The Export Hardware dialog box opens.

2. Ensure that the Include Bitstream check box is checked and that the Export to field is set to the
default option of <Local to Project> as shown in Figure 32.
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#- Export Hardware o3

Export hardware platform for software
development tools '

| Indlude bitstream

Export to: | & <Local to Project> -

[ OK || Cancel |

Figure 32: Export Hardware for SDK

3. Click OK.
4. To launch SDK, select File > Launch SDK.
The Launch SDK dialog box opens.

5. Accept the default selections for Exported location and Workspace and click OK.

# Launch SDK X
Launch software development tool. ‘
Exported location: | & <Local to Project>  ~
Workspace: | &7 <Local to Project> -
[ OK ] | Cancel |

Figure 33: Launch SDK Dialog Box

Conclusion

In this lab, you:

e Created a Vivado project that includes a Zyng-7000 AP SoC processor design using the IP
Integrator tool.

e Instantiated IP in the IP Integrator tool and made the necessary connections utilizing the
Designer Assistance feature.

e Marked nets for debug, to analyze them in the Vivado Integrated Logic Analyzer.
e Inserted debug probes in the design to debug it later in the Vivado Integrated Logic Analyzer.

e Synthesized, implemented, and generated the bitstream before exporting the hardware
definition to SDK.
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Lab Files

You can use the Tcl file 1abl. tcl that is included with this tutorial design files to perform all the steps
in this lab.

To use the Tcl script, launch Vivado and type source labl.tcl inthe Tcl console.

Alternatively, you can also run the script in the batch mode by typing Vivado -mode batch -source
labl.tcl at the command prompt.

Note: You must modify the project path in the 1ab1 . tc1 file to source the Tcl files correctly.
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Lab 2: Using SDK and the Vivado IDE Logic Analyzer

Introduction

You can run this lab after Lab 1. Make sure that you followed all the steps in Lab 1 before proceeding.

Step 1: Start SDK and Create a Software Application

1. If you are doing this lab as a continuation of Lab 1, then SDK should have launched in a separate
window. You can also start SDK from the Windows Start menu by clicking on Start > All Programs
> Xilinx Design Tools > Vivado 2016.1 > Xilinx SDK 2016.1.

When starting SDK in this manner you need to ensure that you in the correct workspace. You can
do that by clicking on File > Switch Workspace > Other in SDK. In the Workspace Launcher dialog
box in the Workspace field, point to the SDK_Export folder where you had exported your
hardware from lab 1. Usually, this is located at . . \project name\project name.sdk.

Note: Changing the workspace relaunches the SDK tool to load the appropriate data.
Now you can create a software application.
2. Select File > New > Application Project.

The New Project dialog box opens.
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3.

-

In the Project Name field, type the name desired, or type Zyng Design.

@ New Project

Application Project

Create a managed make application project.

Project name: Zyng_Design
Use default location
Chtutorials\2015.1\ug940\ab1\labl.sdk\Zyng_Design

default =

= E S

Browse...

OS Platform: lstandalone

Target Hardware

Hardware Platform: [zynq_design_l_wrapper_hw _platform_0

Processor: [ps}’_corte)(ag_[)

Target Software
Language: @C ©C++
Board Support Package: (@ Create New  Zyng_Design_bsp

Use existing

@:l < Back Next = ] [ Finish ] [

Cancel

4. Click Next.

Embedded Processor Hardware Design

Figure 34: SDK Application Project
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5. From the Available Templates, select Peripheral Tests as shown in Figure 35.

-

New Project = E
Templates ,E
Create one of the available templates to generate a fully-functioning application
project.

Available Templates:

OpenAMP echo-test

OpenAMP matrix multiplication Demo
OpenAMP RPC Demao

Peripheral Tests

RSA Authentication App

Zyng DRAM tests

Zyng FSBL

Dhrystone Simple test routines for all peripherals in the  »
Empty Application hardware.

Hello World

IwIP Echo Server

Memory Tests

] [ Cancel

Figure 35: SDK New Project Template

6. Click Finish.

When the program finishes compiling, you see the following in the Console window.

il Problems ¥ Tasks & Console 2 |[O Properties B SDK Terminal

4 4 B EB

= O

"B B~

A § . AT o o LEL™ M= e ey ey

"Finished building: Zyng Design.elf.size'

11:42:43 Build Finished (took 55.183ms)

Figure 36: SDK Message
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Step 2: Run the Software Application

Now, run the peripheral test application on the ZC702 board. To do so, you need to configure the JTAG
port.

1.

Ensure that your hardware is powered on and a Digilent Cable or the USB Platform Cable is
connected to the host PC. Also, ensure that you have a USB cable connected to the UART port of
the ZC702 board.

Download the bitstream into the FPGA by selecting Xilinx Tools > Program FPGA.
The Program FPGA dialog box opens.

Ensure that the Bitstream field shows the bitstream file that you created in Step 7 of Lab 1, and then
click Program.

Note: The DONE LED on the board turns green if the programming is successful. You should also see
an INFO message suggesting that the FPGA was configured successfully in the SDK Log window.

In the Project Explorer, select and right-click the Zynq_Design application.
Select Debug As > Debug Configurations.

In the Debug Configurations dialog box, right-click Xilinx C/C++ application (System Debugger)
and select New.

In the Debug Configurations dialog box, click Debug, as shown in the following figure:
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m Debug Configurations

Create, manage, and run configurations

Run or Debug a program using System Debugger.

CExX| B~

type filter text

E Performance Analysis
[ Target Communication Framework
& Xilinx C/C++ application (GDB)
£ Xilinx C/C++ application (System Debugger on QEMU)
4 £ Xilink C/C++ application (System Debugger)
£ Zyng_Design Debug

< 1 »
Filter matched 6 of 16 items

@

Name: Zyng_Design Debug

@® Target Setup . (5 Application | ¢ Arguments| B8 Environment| 5+ Symbol Files| % Source| & Path Map| &l Common

Debug Type: IS‘tandaIcne Application Debug 'l

B[

Connection: lLocaI

Hardware platform: [zynq,design,lfwrapperﬁhw;)laﬁormﬁ 'l

Bitstream file: zyng_design_1_wrapper.bit ISearch‘..l [Bmwseml IGenerate‘..l

Initialization file: ps7_inittcl

FPGA Device: Auto Detect

PS Device: Auto Detect

Summary of operations to be performed
[ Reset entire system
0 Program FPGA
Run ps7_init
Run ps7_post_config
[C] Enable Cross-Triggering

Following operations will be performed before launching the debugger. -~
1. Runs ps7_init.
2. Runs ps7_post_config. Enables level shifters from PL to PS. (Recommended to use this option
only after system reset or board power ON}
3. The following processors will be reset and suspended.

1) ps7_cortexa8_0
4. All pracessors in the system will be suspended, and Applications will be downloaded to the
following processors as specified in the Applications tab.

1) ps7_cortexa9_0

Apply Revert

Debug J [ Close

Figure 37: Run Debug Configurations

The Confirm Perspective Switch dialog box opens.

8. Click Yes.

9. Set the terminal by selecting the SDK Terminal tab and clicking the |/ icon.

10. Use the settings in Figure 38 for the ZC702 board. The COM Port might be different on your

machine.
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Connect to serial port L

Basic Settings
Port: COM3 -

Baud Rate: | 115200 v

~ Advance Settings

Data Bits: lB VI
Stop Bits: ll vl
Parity: lNDne VI
Flow Control: lNone vl

Timeout (sec):

oK ] l Cancel ]

Figure 38: Terminal Settings for ZC702 Board

11. Click OK.
12. Verify the Terminal connection by checking the status at the top of the tab.

B Console ¥ Tasks B SDK Terminal 22 [l Problems 3 Executables o X L = O

Connected to: Serial { COM3, 115200,0,8)

Connected to COM3 at 115200

Figure 39: Terminal Connection Verification
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13. In the Debug tab, expand the tree to see the processor core on which the program is running, as
shown in Figure 40.

%% Debug 2
% <unknown =
4 £ Zyng Design Debug (Local)
4 5% APU
4 g% ARM Cortex-A9 MPCore #0 (Breakpoint: main)
= 0x00100578 main(): ./src/testperiph.c, ling 65
0%0010e8e0 _start(): xil-crt0.S, line 133

s ARM Cortex-A9 MPCore #1 (Running)
xc7z020

Figure 40: Processor Core to Debug

14. If testperiph.c is not already open, select . . /src/testperiph.c, double-click it to open
that location

Add a Breakpoint
Next, add a breakpoint on line 106.
1. From the main menu, select Navigate > Go To Line.

2. Inthe Go To Line dialog box, type 106 and click OK.

TIP: If line numbers are not visible, right-click in the blue bar on the left side of the window and
select Show Line Numbers.

3. Double-click in the blue bar to the left of line 106 to add a breakpoint on that line of source code,
shown in Figure 41.

print("\r\nRunning GpioQutputExample() for axi_gpio @...\r\n");
status = GpioOutputExample(XPAR_AXI GPIO_© DEVICE ID,4);

if (status == @) {
print("GpioOutputExample PASSED.\r\n");
}
else {
print("GpioOutputExample FAILED.\r\n");
}

Figure 41: Add a Breakpoint
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Step 3: Connect to the Vivado Logic Analyzer

1
2.

© N o w

Connect to the ZC702 board using the Vivado® logic analyzer.

Open the Vivado project from Lab 1: Programming a Zyng-7000 AP SoC Processor if it is not already
open.

From the Program and Debug drop-down list in the Flow Navigator > Program and Debug, select
Open Hardware Manager.

In the Hardware Manager window, click Open target and select Open New Target to open a
connection to the Digilent JTAG cable for ZC702, as shown below in Figure 42.

Hardware Manager - unconnected

(i) Mo hardware target is open. Open target

Hardware E.  Auto connect

e T =|E K p M Recent Targets »
r

r

Name Status

& Open New Target...

Figure 42: Launch Open New Hardware Target Wizard

The Open New Hardware Target dialog box opens.
Click Next.

Click Next on the Hardware Server Settings page.
Click Next on the Select Hardware Target page.
Click Finish.

When the Vivado hardware session successfully connects to the ZC702 board, the Hardware window
shows the following information:

Hardware — 0O a x
A= AR N
Name Status
=t B localhost (1) Connected
E}-EG xilinx_tcf/Digilent/2102033423... Open
@ arm_dap_0 (0) M/A
xc72020_1 (2 Programmed
-~ XADC (System Monitor)
~5€ hw_ila_1 (u_ila_0) ) Idle

Figure 43: Successfully Programmed Hardware Session
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Lab 2: Using SDK and the Vivado IDE Logic Analyzer

core is active and capturing data. To do this, select the Status tab of the

hw ila 1 inthe Hardware Manager.

10. Click the Run Trigger Immediate button

hw_ila_1
Settings - hw_ila_1
Trigger Mode Settings
Trigger mode: | BASIC_ONLY -
Capture Mode Settings
ALWAYS -~

Capture mode:

General Settings

Refresh rate: 500 ms

b on the hw_ila_1 window.

—Oax
Status - hw_ila_1 — o=
Y core status
‘ Idle Waiting for Trigger Post-Trigger Full
Capture status
Run trigger immediate for this ILA coreh o of 1024 Total sample 0 of 1024
Idle Idle Idle
Trigger Setup - hw_ila_1 — 0O x Capture Setup - hw_ila_1 — 0O x
+
ess the =4+ bu e o e -

D
Waveform - hw_ila_1 — o=

Figure 44: Run Trigger Inmediate to capture static data
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Static data from the ILA core displays in the waveform window as shown in Figure 45.

Waveform - hw_ila_1

g

== i ]

==

Figure 45: Static Data from the hardware

11. Set up a condition that triggers when the application code writes to the GPIO peripheral. To do this:
a. From the menu select Window > Debug Probes.

b. Select, drag and drop the
/zyng_design 1 i/processing system7 0 axi periph MO0 AXI AWVALID signal
from the Debug Probes window into the Trigger Setup window.

Debug Probes —Ow = A1 Vivado Journal x| ® hw_ila_1 %

g G i | ]

AI=E Settings - hw_ila_1 0O x Status - hw_ila_1
Trigger Mode Settings & Core status

/processing_system7_0_axi_periph_MO00_AXI_ARADD
{processing_system7_0_axi_periph_M00_AXI_ARREA Trigger mode: | BASIC_ONLY Idle Waiting for Trigger Post-Trigger Fu
{processing_system7_0_axi_periph_MO0O_AXI_ARVAL bb Capture status

/processing_system?7_0_axi_periph_M00_AXT AWADL

- Window 1 of 1 Window sample 0 of 1024  Total sample 0 of 1024
{processing_system7_0_axi_periph_MO0_AXI_AWREZ Capture Mode Settings P P
Idle Idle Idle
Capture mode: AL
{processing_system7_0_axi_periph_MO00_AXI_BREAD' o
{processing_system7_0_axi_periph_M00_AXI_BRESP[ Number of windows: 1 Trigger Setup - hw_ila_1 — O = Capture Setup - hw
{processing_system7_0_axi_periph_MO00_AXI_BVALID 10| & Name

{processing_system7_0_axi_periph_MO0_AXI_RDATA

Trigge ition in window: |0 + B
{processing_system7_0_axi_periph_MO00_AXI_RREAD Tigger position in Windg

/processing_system7_0_axi_periph_MO0_AXI_RRESP| General Settings ALWAYS to Bl
/processing_system7_0_axi_periph_MO0_AXI_RVALIC h =D 2 o .
{processing_system7_0_axi_periph_MO0_AXI WDAT Refresh rate: |500 f

/processing_system7_0_axi_periph_MO00_AXI WREAL | * Waveform - hw_ila_1

{processing_system7_0_axi_periph_MO0_AXI WSTRE 3 —
{processin stem7_0_axi_periph_MO0_AXT WVALII
P e —-ax_peripn _HRL_AA Name Value

Figure 46: The ILA Properties window
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c. Click the Compare Value column of the *WVALID row, as shown in Figure 47.

Trigger Setup - hw_ila_1 _ 0O =
A Compare Value
o

== (equal)

Operator:

=D,

“I Radix: [B] (Binary) 2
Waveform - H value: 1 (logical one) 7
0

[ DK ] ’ Cancel

= name

Figure 47: ILA Properties Window

d. Ensure that the Radix is set to [B] binary.
e. Change the value from an X to a 1, and click OK.

12. You also want to see several samples of the captured data before and after the trigger condition.
Change the trigger position to the middle of the 1024 sample window by setting the Trigger
Position in window for the hw_ial_1 core in the ILA Properties window to 512 and then pressing
Enter, as shown below.

Settings - hw_ila_1 — O =
Trigger Mode Settings

Trigger mode: | BASIC_ONLY hd

Capture Mode Settings

Capture mode: ALWAYS -

Number of windows: 1 [1-103
Window data depth: 1024 ~ | [1-1024
Trigger position in window: (512 [0-102

General Settings

Refresh rate: 500 ms

Figure 48: Change Debug Probe Settings

After setting up the compare value and the trigger position, you can arm the ILA core.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 40
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=40

& XILINX

ALL PROGRAMMABLE, Lab 2: Using SDK and the Vivado IDE Logic Analyzer

13. In the Hardware window, select the hw_ila 1 core, and then click the Run Trigger button Pl

Alternatively, you can arm the ILA core directly from the ILA Properties window by clicking the Run
Trigger Pl button.
14. Notice that the Status window of the hw _ila 1 ILA core changes from:
o Idle to Waiting for Trigger.

o Likewise, the Hardware window shows the Core Status as Waiting for Trigger, as shown in

Figure 49.
Hardware — 02 % | status- hw_ila_1 _ o=
Q. T 2| [E M
N s = | Dl b & Core status
Name Status Idle Pre-Trigger \Waiting for Trigger Post-Trigger Full
=+ B localhost (1) Connected b
= Be xilin tcf/Digilent/2102033... Open Capture status
@ arm_dap_0 (0) N/A Window 1 of 1 Window sample 512 of 1024  Total sample 512 of 1024
= xc72020_1 (2) Programmed i 100% 50% 50%
-gE XADC (System Monitor)
@ Waiting For Trigger.
Trigger Setup - hw_ila_1 — O x Capture Setup - hw_ila_1 S
o Compare Value ™~
= ystem7_0_axi_periph_M0O0_AXI_AWVALID = [B] 1 -
- ==| Toadd a capture equation change the
capture mode for 'hw_ila_1' from ALWAYS
D 1| tosasic

Figure 49: Status of hw_ila_1

15. Go back to SDK and continue to execute code. To do so, click the Resume button " on the SDK
toolbar.

Alternatively, you can press F8 to resume code execution.

The code execution stops at the breakpoint you set on line 106. By this time, at least one write
operation has been done to the GPIO peripheral. These write operations cause the WVALID signal
to go from 0 to 1, thereby triggering the ILA core.

Note: The trigger mark occurs at the first occurrence of the AWVALID signal going to a 1, as shown in

Figure 50.
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hw_ila_1 — 0O a =

Waveform - hw_ila_1 —

004

Figure 50: Trigger Mark Goes to 1

16. If you are going on to Lab 3, close your project by selecting File > Close Project.

You can also close the SDK window by selecting File > Exit.

Conclusion

This lab introduced you to software development in SDK and executing the code on the Zyng-7000 AP
SoC processor.

This lab also introduced you to the Vivado Logic Analyzer and analyzing the nets that were marked for
debug in Lab 1 and cross-probing between hardware and software.

Note: Tcl files are not provided for this lab as the intent is for the user to see the power of cross-probing
between the hardware and software in the GUI environment.
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Introduction
In this lab, you use the cross-trigger functionality between the Zynq®-7000 AP SoC processor and the
fabric logic.

IMPORTANT: Cross-triggering is a powerful feature that you can use to co-debug software

ﬁ running in real time on the target hardware. This tutorial guides you from design creation
in IP integrator, to marking the nets for debug and manipulating the design to stitch up the
cross-trigger functionality.

Step 1: Start the Vivado IDE and Create a Project

1. Start the Vivado® IDE by clicking the Vivado desktop icon or by typing vivado at a command
prompt.

2. From the Quick Start page, select Create New Project.

3. In the New Project dialog box, use the following settings:
a. In the Project Name dialog box, type the project name and location.
b. Make sure that the Create project subdirectory check box is checked. Click Next.
c. Inthe Project Type dialog box, select RTL project. Click Next.

d. Inthe Add Sources dialog box, set the Target language to either VHDL or Verilog. You can
leave the Simulator language selection to Mixed. Click Next.

e. In Add Existing IP dialog box, click Next.
f. In Add Constraints dialog box, click Next.

g. Inthe Default Part dialog box, select Boards and choose ZYNQ-7 ZC702 Evaluation Board
that matches the version of hardware that you have. Click Next.

h. Review the project summary in the New Project Summary dialog box before clicking Finish to
create the project.
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Step 2: Create an IP Integrator Design

1.
2.

In Vivado Flow Navigator, click Create Block Design.

In the Create Block Design dialog box, specify zyng processor system as the name of the
block design.

Leave the Directory field set to its default value of <Local to Project> and the Specify source set
field to Design Sources.

Click OK.
The IP integrator diagram window opens.

Click the Add IP icon in the block design canvas, as shown in Figure 51.

This design is empty. Press the 3 button to add TF

Figure 51: Add IP to the Design

The IP catalog opens.
In the Search field, type Zyng, select the ZYNQ7 Processing System IP, and press Enter.
Alternatively, double-click the ZYNQ7 Processing System IP to instantiate it as shown in Figure 52.

IP Details =
Search: zyng (1 match)
5| Mame: IYNQ7? Processing System
|| version: 5.5 (Rev. 3)

Interfaces: AXI4, AXI4-Stream
Description: Arm dual core SOC with Zynq fpga

Status: Production

License: Included

Change Log: View Change Lo

Vendor: Xilinx, Inc.

VLNV xilinx.com:ip:processing_system7:5.5

Repository:  c:/Xilinx/Vivado/2016.1/data/ip

ENTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 52: Instantiate the ZYNQ7 Processing System
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7. In the header at the top of the diagram, click Run Block Automation as shown in Figure 53.

&= Diagram X | B Address Editor X
#[]| # zynq_processor_system

O¢| (@ Designer Assistance available. Run Block Automation

Figure 53: Run Block Automation on Zynq Processing System

The Run Block Automation dialog box states that the FIXED 10 and the DDR pins on the ZYNQ7
Processing System 7 IP will be connected to external interface ports. Also, because you chose the
ZC702 board as your target board, the Apply Board Preset checkbox is checked by default.

8. Enable the Cross Trigger In and Cross Trigger Out functionality by setting those fields to New ILA,
then click OK, as shown in Figure 54.

¢ Run Block Automation [ 53]
Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its
configuration options on the right. ‘
@ =H{¥] All Automation (1 out of 1 selected) Description
= ik dnrocessing_system7_0
‘f‘ This option sets the board preset on the Processing System. All current
= properties will be overwritten by the board preset. This action cannot be undone.

Zynq?7 block automation applies current board preset and generates external
connections for FIXED_IO, Trigger and DDR interfaces.

MOTE: Apply Board Preset will discard existing IP configuration - please uncheck
this box, if you wish to retain previous configuration.

Instance: /processing_system7_0
Options
Make Interface External: FIXED_IO, DDR

Apply Board Preset:
Cross Trigger In: New ILA ~
Cross Trigger Out: New ILA ~

0K l [ Cancel

Figure 54: Run Block Automation Dialog Box

This instantiates an ILA core in the design and also connects the TRIGGER IN 0 and TRIGGER OUT 0
interface pins of the PS7 to the ILA. The automation also connects the DDR and FIXED IO interface
pins to external I/O ports as show in Figure 55.
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processing_system7_0

DDR =
FIXED IO

DDR
ia 0 FIXED_IO
USBIND_0<F =

M_AXI_GPO<- (i} ||| TRIG_IN
4= TRIGGER_IN_O W TRIGGER_OUT_0<F |J 4-SLOT_O_AXI  TRIG_OUT 4 ||t
M_AXI_GPO_ACLK ZYNQ TTCO_WAVED_OUT ck

TTCO_WAVEL OUT
TTCO_WAVEZ_OUT
FCLK_CLKO
FCLK_RESETO_N

)

—

ILA (Integrated Logic Analyzer)

ZYNQ7 Processing System

Figure 55: IP Integrator Canvas After Running Block Automation

9. Add the AXI GPIO and AXI BRAM Controller to the design by right-clicking anywhere in the diagram
and selecting Add IP.

The diagram area should look like Figure 56.

processing_system7_0

DDR 4=
FIXED_IO<-
USBIND_04-
M_AXL_GPO -
|[2TrRIGGER_IN_0 W TRIGGER_OUT_0d=
M_AXI_GPO_ACLK ZYNQ TTCO_WAVED_OUT
TTCO_WAVEL_OUT

TTCO_WAVE2_OUT

FCLK_CLKO

FCLK_RESETO_N

DDR
a0 FIXED_IO
|I|4= TRIG_IN

qrSLOT_O_AXI  TRIG_OUTH= l—
clk

ILA (Integrated Logic Analyzer)

T Tp—

axi_bram_ctrl_0

E‘{NQ? Processing System axi_gpio_0 ~
. i 4R 5_AXI

s_axi_adk

S_axi_aresetn

BRAM_PORTA=: (||
BRAM_PORTB<: |||

AXI BRAM Controller

AXI GPIO

Figure 56: Diagram after Instantiating IP for This Design

10. Click the Run Connection Automation link at the top of the Diagram window.
The Run Connection Automation dialog box opens.

11. Select the All Automation (5 out of 5 selected) checkbox. This selects connection automation for all
the interfaces in the design. Select each automation to see the available options for that automation
in the right pane.
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12. Make each of the following connections using the Run Connection Automation function.

Connection

More Information

Setting

axi_bram_ctrl 0

e BRAM_PORTA

The Run Connection Automation dialog box
informs you that a new Block Memory
Generator IP will be instantiated and
connected to the AXI BRAM Controller
PORTA.

No options.

axi_bram_ctrl 0

e BRAM_PORTB

Note that the Run Connection Automation
dialog box offers two choices now. The first
one is to use the existing Block Memory
Generator from the previous step or you can
chose to instantiate a new Block Memory
Generator if desired.

In this case, use the existing BMG.

Leave the Blk_Mem_Gen
field set to its default
value of Blk_ Mem_Gen
of BRAM_PORTA.

axi_bram_ctrl 0

e S AXI

The Run Connection Automation dialog box
states that the S_AXI port of the AXI BRAM
Controller will be connected to the
M_AXI_GPO port of the ZYNQ7 Processing
System IP.

The AXI BRAM Controller needs to be
connected to a Block Memory Generator
block. The connection automation feature
offers this automation by instantiating the
Block Memory Generator IP and making
appropriate connections to the AXI BRAM
Controller.

Leave the Clock
Connection (for
unconnected clks) field
set to Auto.

axi_gpio_0
e GPIO

The Run Connection Automation dialog box
shows the interfaces that are available on
the ZC702 board to connect to the GPIO.

Select LEDs_4Bits.

axi_gpio_0
e S AXI

The Run Connection Automation dialog box
states that the S_AXI pin of the GPIO IP will
be connected to the M_AXI_GPO pin of the
ZYNQ7 Processing System. It also offers a
choice for different clock sources that might
be relevant to the design.

Leave the Clock
Connection (for
unconnected clks) field
set to Auto.
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When these connections are complete, the IP integrator design looks like Figure 57.

— O e ¥

rst_processing_system?_0_S0M rocessing_system?__axi_perigh

DR
FIXED_ID

Figure 57: Design after Running Connection Automation

13. Click the Address Editor tab of the design to ensure that addresses for the memory-mapped slaves
have been assigned properly. Expand Data by clicking the + sign. Change the range of the AXI
BRAM Controller to 64K, as shown below.

%= Diagram X | i Address Editor %

A el Slave Interface Base Name  Offset Address Range  High Address
e

=2a [=F4F processing_system?7_0

5_AXI Re Oxd4120_0000 64K v 0x4120_FFFF

C o Josdooo cooo T |
8K &
16K ‘

Figure 58: Memory Map the Slaves

Mark Nets for Debug

Next, you will mark some nets for debug.

1. Click the Diagram tab again and select the net connecting the gpio pin of the AXI GPIO IP to the
LEDs_4Bits port.

2. Right-click in the IP integrator diagram area and select Mark Debug. This marks the net for debug.
The ILA insertion for debugging this net will be done after the design is synthesized.

3. Notice that a bug symbol appears on the net to be debugged. You can also see this bug symbol in
the Design Hierarchy window on the selected net.
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Likewise, you will mark the net connecting the interfaces TRIG IN of the i1a 0 and
TRIGGER OUT 0 of processing_system7_0. Marking these cross-trigger nets for debug will enable
you to view these signals in the ILA.

Notice also that the SLOT 0 AXT interface port of the ILA is yet to be connected. These interfaces
are designed to monitor an AXI interface. You will monitor the net between s AXT interface of AXI
GPIO and M00_AXT interface of the AXI Interconnect (processing system7 0 axi periph).
To monitor this interface, hover the cursor on the SLOT_0_AXI interface port of the ila_0 until it
changes into a pencil, and click and drag over to the net to be monitored (S_AXI interface of GPIO).

The clk pin of the ILA is not yet connected either. Connect it to the FCLK CLKO pin of the ZYNQ7
Processing System.

Click the Regenerate Layout button P to generate an optimal layout of the design. The design
should look like Figure 59.

Diagram — 0O & %

3 4, zynq_processor_system »

o

L RpQE G BHLAOOEER A

processing_system7_0

oodh|| {3 DDR
5o FxED_todk|| [ FIXED_IO
. usao_adk|| axi_gpio_0
][l Trac I i processing_system?_0_axi_periph
it - - kil I s
o TG outds ||| e o ZYNCJ‘ TRIGGER_0uT a<k(| = /M T IS leds_4bits
el [M_AKI_GPO_ACLK. TTCO_WAVED_OUT - b y i
a2 _aresem
TTCO_WAVE] QUT f=
ILA (Irteqrated Loaic Analyze e —
| TTCO_WAVEZ 0UT s Fel ) AXI GPIO
FOLK_CLKO —— = M0 b axi_bram_etd_0
ARESETH 6= ] —_— axi_bram_ctrd_0_bram
FCLK_RESETO_Np=— o ML AXTelh [y s s
- (- BRAM_PORTA: ||| :BRAM_PORTA
ZYNQ7 Processing System ARESETH ad ek poRTER | ||lRr2a04_poaTs
ALK | axi_aresem
ARESETH — Black Memary Gengratar
AXI BRAM Controller
rst_processing_system?_0_50M AXT Intercornect

e e ml_reset

reset in bus_skuct resed]0:0]
—eux_reset_in pesigheral_reseq0:0]
—{mi_debug_sys_rst aresetsio ]
—dem Jacked pesiaheral_sresein[0:0]

Processar System Resel

10.

Figure 59: Block Design after Running Regenerate Layout

Click the Validate Design button to run Design Rule Checks on the design .

After design validation is complete, the Validate Design dialog box opens to verify that there are
no errors or critical warnings in the design.

Click OK.
Select File > Save Block Design to save the IP integrator design.
Alternatively, press Ctrl + S to save the design.

In the Sources window, right-click the block design, zyng processor system, and select
Generate Output Products.
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The Generate Output Products dialog box opens.

-

¢ Generate Output Products | &3 |

y

The following output products will be generated.

Preview

@ k4, zyng_processor_system.bd (Global)
= j Synthesis
[ Implementation

p
= H . .
~- I Simulation

Synthesis Options

(@) Global

(") out of context per TP

(") out of context per Block Design
Run Settings

Mumber of jobs:| 4 -

Apply Generate H Cancel

Figure 60: Generate Output Products Dialog Box

11. Click Generate.
12. Click OK on the Generate Output Products dialog box.
13. In the Sources window, right-click zyng processor system, and select Create HDL Wrapper.
The Create HDL Wrapper dialog box offers two choices:
o The first choice is to generate a wrapper file that you can edit.

o The second choice is let Vivado generate and manage the wrapper file, meaning it is a read-
only file.

14. Keep the default setting, shown in Figure 61, and click OK.

¢ Create HDL Wrapper | =2 |

You can either add or copy the HDL wrapper file to the project. Use copy option if you
would like to modify this file.

Options
() Copy generated wrapper to allow user edits

(@) Let Vivado manage wrapper and auto-update

Figure 61: Create HDL Wrapper Dialog Box
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Step 3: Synthesize Design
1. From the Flow Navigator, under Synthesis, click Run Synthesis.

2. When synthesis completes, select Open Synthesized Design from the Synthesis Completed dialog
box and click OK as shown in Figure 62.

You can also click Synthesis > Open Synthesized Design in Flow Navigator.

Synthesis Completed 28

':0] Synthesis successfully completed.

Mext

Run Implementation
@) Open Synthesized Design

View Reports

Don't show this dialog again

[ oK ]| Cancel |

Figure 62: Open Synthesized Design

Step 4: Insert an Integrated Logic Analyzer Debug Core

When the synthesized design schematic opens, the Debug window also opens. In the Debug window,
notice that there is one ILA, 11a 0, that has already been inserted in the design. This ILA was
instantiated in the block design and will monitor the AXI transactions to the GPIO. Notice that there are
the 4 bits of output leds_4bits and the cross-trigger pins that were also marked for debug in the block
design. These outputs have not yet been assigned to an ILA. You now insert the ILA to monitor these
output bits.
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Debug — O o =

Name

=4 dbg_hub (labtools_xsdbmasterlib_v3)
. B8 ila_0 (labtools_ila_v4)
== Unassigned Debug Mets (4)

=i zyng_processor_system_i/axi_gpio_0_GPIO_TRI_O (4)
- ' zyng_processor_system_i/axi_gpio_0_GPIO_TRI_O[0]
- It zyng_processor_system_i/axi_gpio_0_GPIO_TRI_O[1]
-+ ' zyng_processor_system_ifaxi_gpio_0_GPIO_TRI_0O[2]
- ' zyng_processor_system_i/axi_gpio_0_GPIO_TRI_O[3]

4| (1] | §
Debug Cores | Debug Nets

W ie B b 4 |FH G K P

Figure 63: Unassigned Debug Nets

1. From the Vivado main menu, select Tools > Set up Debug.

Alternatively, from the left side of the Debug window, click the Set up Debug button .
The Set up Debug dialog box opens as shown in Figure 64.
2. Click Next.

¢ Set Up Debug

=

Set Up Debug

\”VADO' This wizard will guide you through the process of

1. Cheosing nets and connecting them to debug cores.

2. Associating a clock domain with each of the nets chosen for debug.

3. Choosing additional features on the debug cores like Data Depth, Advanced Trigger
mode and Capture Control.

Note: This setup wizard does not apply to the VIO, IBERT or JTAG-to-AXI-Master debug
cores. Please refer to Vivado Design Suite User Guide: Programming and Debugging
(UG908) for further instructions on how to use these IPs.

XILINX

ALL PROGRAMMABLE.

To continue, click Next

< Back Finish

Figure 64: Set Up Debug Dialog Box

3. Inthe Nets to Debug page, select the nets that you are interested in monitoring from the list of nets
offered, as shown in Figure 65.

4. Click the Find Nets to Add button at the bottom of the dialog box.
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#- Set Up Debug &3
Nets to Debug
The nets below will be debugged with ILA cores. To add nets click "Find Nets to Add™. You can also select '
nets in the Metlist or other windows, then drag them to the list or dick "Add Selected Nets".
5| Name Clock Domain  Driver Cell TRIG DA...
va |[F} 88 zynq_processor_system_i/axi_gpio_0_GPL.. zynq_processo... FORE W W
iy
£
[T
B
X
" Find Nets to Add... | Nets to debug: 4
[ <pack |[ mest> Eir [ cancel |

Figure 65: Add Nets to Debug

5. In the find Nets dialog box, shown in Figure 66, change the Properties to select MARK_DEBUG from
the first drop-down list. This will show all the nets that have the MARK DEBUG attribute set.

4. Find Nets | &
Find objects in the current design or device by filtering Tcl properties and objects. ‘
Properties

MARK_DEBUG v |lis v | true v |4

["] Regular expression Search hierarchically Display unique nets
Of objects: E]
Command: | show_objects -name NET_OMLY [get_nets -hierarchical -top_net_of_hierarchical_group -filter { MARK_DEBUG == "TRUE" } ]

’ oK ” Cancel ]

Figure 66: Find Nets with MARK_DEBUG Attribute

6. Click OK. The Add Nets to Debug dialog box opens.
7. Select the following nets, as shown in Figure 67:
e zynqg_processor_system_i/ila_0_TRIG_OUT_ACK
e zyng_processor_system_i/ila_0_TRIG_OUT_TRIG
e zynq_processor_system_i/processing_system7_0_TRIGGER_OUT_0_ACK
e zynq_processor_system_i/processing_system7_0_TRIGGOUT_OUT_O_TRIG
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8. Click OK.

s

#- Add Nets to Debug

Select the nets you want to add.

Q| H 1" zynq_processor_system_i/axi_gpio_0_GPIO_TRI_O (4

e | 41 0 Zyng_processor_system_i/processing_system7_0_axi_periph_M00_AXI_ARADDR (9
| ) [P o zynq_processor_system_i/processing_system7_0_axi_periph_MOO_AXI_AWADDR (2

£ f o zynq_processor_system_i/processing_system?7_0_axi_periph_MO0O0_AXI_WDATA (32
o stem u/rocessm stem?_0_axi_periph_MO0O0_AXI_WSTRS (-

T zynq_processor_system_i/processing_system?7_0_axi_periph_M00_AXI_ARREADY
J© zynq_processor_system_i/processing_system?7_0_axi_periph_M00_AXI_ARVALID
J @ zynq_processor_system_i/processing_system?7_0_axi_periph_MO0_AXI_AWREADY
Jt zynq_processor_system_i/processing_system7_0_axi_periph_MO0_AXI_AWVALID
J 1 zynq_processor_system_i/processing_system7_0_axi_periph_MO00_AXI_BREADY
Tt zynq_processor_system_i/processing_system?7_0_axi_periph_MO00_AXI_BRESP[0]
J© zynq_processor_system_i/processing_system7_0_axi_periph_MO00_AXI_BVALID
5 zynq_processor_system_i/processing_system7_0_axi_periph_M00_AXI_RDATA[0]
Jt1 zynq_processor_system_i/processing_system7_0_axi_periph_MO0_AXI_RDATA[1]
J& zynq_processor_system_i/processing_system7_0_axi_periph_M0OO_AXI_RDATA[2]
J 1 zynq_processor_system_i/processing_system?7_0_axi_periph_MO0_AXI_RDATA[3]
J & zynq_processor_system_i/processing_system7_0_axi_periph_MO00_AXI_RREADY
Tt zynq_processor_system_i nlprocessmg_sysem7 0_axi _penph MOO_AXI_RVALID

r i/ 0_

Figure 67: Add Nets Connected to Cross-Trigger Pins

The additional cross-trigger nets are added to the ILA in the Set Up Debug dialog box.

9. Click Next.

.

#- Set Up Debug
Nets to Debug

The nets belowr will be debugged with ILA cores. To add nets click "Find Mets to Add". You can also select ‘
nets in the Metlist or other windows, then drag them to the list or click "Add Selected Mets".

(=]

N MName Clock Domain
= I zyng_processor_system_if/axi_gpio_0_GPIO_TRI_O (4) zyng_processor_system_i/processing_system7_0_FCLK
% I zyng_processor_system_i/ila_0_TRIG_OUT_ACK zyng_processor_system_ifprocessing_system7_0_FCLK
I: I zyng_processor_system_ifila_0_TRIG_OUT_TRIG zyng_processor_system_ifprocessing_system7_0_FCLK
- ' zyngq_processor_system_i/processing_system?_0_T... zyng_processor_system_i/processing_system7_0_FCLK
[lIf] * I zynq_processor_system_i/processing_system7_0_T... zynq_processor_system_i/processing_system7_0_FCLK
1
s
X
] 1] =]
| Find Nets to Add... Nets to debug: 8
| <Back | Next> | Finish Cancel
Figure 68: Specify Nets for Debugging
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The ILA (Integrated Logic Analyzer) Core Options dialog box opens as shown in Figure 69.

e

=

¢ Set Up Debug
ILA Core Options
Choose features for the ILA& debug cores. ‘

Sample of data depth: | 1024 -
Input pipe stages: o0 -
Trigger and Storage Settings
Capture control
Advanced trigger

l < Back ” Next = ] Finish

Figure 69: Enable Advanced Trigger and Capture Modes
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10. In the ILA (Integrated Logic Analyzer) Core Options page, do the following:

a. Leave the Sample of Data Depth and Input Pipe Stages options to their default values of 1024
and 0, respectively.

b. Select both Capture Control and Advanced Trigger check boxes.
c. Click Next.

11. Review the Set up Debug Summary dialog box and click Finish.

The debug nets are now assigned to the ILA u _ila 0 debug core, as shown in Figure 70. Notice
that there are now no nets under the Unassigned Debug Nets folder.

Debug -0 a X
: Name Driver Cell
“i| = @ dbg_hub
21 | Eila_0
9] @ u_ila_0
t e clk
¥ = o probe0 (4
iv @ Cho r_Systs ’ FDRE
- @ Chl FDRE
= @ Ch2 : v d_0f f 2 FDRE
B @ Ch3 y FDRE
=+ probel (!
@ ChoO(zy i T K PS7
= probe2
@ Cho ] FDRE
= probe3
@ Cho € TRI FDRE
= probe4
@ Cho i R PS7
Unassigned Debug Nets
Debug Cores Debug Nets

Figure 70: Debug Nets Assigned to Debug Core
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Step 5: Implement Design and Generate Bitstream

Now that the cross-trigger signals have been connected to the ILA for monitoring, you can complete
the design through the rest of the flow.

1.

Click Generate Bitstream to generate the bitstream for the design. The Save Project dialog box
opens with a message asking whether the project should be saved at this point.

Click Save.

The Out of Date Design dialog box opens informing you that saving the new debug related
constraints could make your synthesis out of date.

Click OK.

The No Implementation Results Available dialog box asks if it is okay to implement the design
before generating the bitstream.

Click Yes.

When bitstream generation completes, the Bitstream Generation Completed dialog box opens,
with the option Open Implemented Design option checked by default.

Click OK to open the implemented design.

You will see a message box that asks about closing synthesized design before opening
implemented design. Click Yes.

Ensure that all timing constraints are met by looking at the Timing Summary tab, as shown in Figure
71. Note that timing could be slightly different in your case.

Timing - Timing Summary - timing_1 — O ax
AZTSE&»d2 4 Design Timing Summary

- General Informat 4

eneral Information Setup Hold Pulse Width

~Timer Settings

[®Dasign Timing Summary Waorst Negative Slack (WNS): 6.885 ns Worst Hold Slack (WHS): 0.036 ns Worst Pulse Width Slack (WPWS): 8.750 ns

~Clock Summary (3) Total Negative Slack (TNS):  0.000 ns Total Hold Slack (THS): 0.000 ns Total Pulse Width Megative Slack (TPWS): 0.000 ns
+1-Check Timing (4) Number of Failing Endpoints: 0 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0
+Intra-Clock Paths Total Number of Endpoints: 18406 Total Number of Endpoints: 18406 Total Number of Endpaints: 9900
+i-Inter-Clock Paths

4-Other Path Groups All user specified timing constraints are met.

+1-User Ignored Paths

+-Unconstrained Paths

« 111 G

Timing Summary - impl_1 X | Timing Summary - timing_1 X 4 kB8

Figure 71: Timing Summary
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Step 6: Export Hardware to SDK

After you generate the bitstream, you must export the hardware to SDK and generate your software
application.

1. Select File > Export > Export Hardware.

2. In the Export Hardware for SDK dialog box, make sure that the Include bitstream check box is
checked, and Export to field is set to <Local to Project>, as shown below in Figure 72.

¢ Export Hardware | =2

Export hardware platform for software
development tools ‘

[#] Include bitstream

Export to: |5 <Local to Project> -

oK ] [ Cancel

Figure 72: Export Hardware for SDK Dialog Box

3. Click OK.

4. Select File > Launch SDK. Make sure that both the Exported location and Workspace fields are
set to <Local to Project>, as shown below in Figure 73.

¢~ Launch SDK =3

Launch software development tool.

Exported location: | &) <Local to Project> -

Workspace: | &1 <Local to Project> -

0K l I Cancel

Figure 73: Launch SDK Dialog Box

5. Click OK.
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Step 7: Build Application Code in SDK

SDK launches in a separate window.
1. After the project has been loaded, select File > New > Application Project.

In the New Project dialog box, as it appears in Figure 74, specify the name for your project. For this
lab, you can use the name peri_test.

-

w New Project o || = | R
Application Project w ﬁ
Create a managed make application project.

Project name: peri_test
Use default location
Chtutorials\2016.1\UG940M lab3\lab3.sdk\peri_test Browse...

default -

05 Platform: lstandalone ']

Target Hardware

Hardware Platform: lzynq_processor_system_wrapper_hWJJIatform_D VI lNew...]
Processor: lps?_cortexag_[} - ]
Target Software
Language: @C ©Cs+

32-bit ~

Board Support Package: (@) Create New  peri_test_bsp

Use existing hd

) < Back Next > l l Finish l [ Cancel

Figure 74: Name the Application Project

2. Click Next.
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3. From the Available Templates, select Peripheral Tests.

@ New Project = E

-

Templates ,f
Create one of the available templates to generate a fully-functioning application
project.

Available Templates:

Dhrystone Simple test routines for all peripherals in the =
Empty Application hardware.

Hello World

IwIP Echo Server

Memory Tests

OpenAMP echo-test

OpenAMP matrix multiplication Demo
OpenAMP RPC Demao

Peripheral Tests

RSA Authentication App

Zyng DRAM tests

Zyng FSBL

@ MNext = Finish ] [ Cancel

Figure 75: Select the Peripheral Tests Template

Click Finish.
Wait for the application to compile.

Make sure that you have connected the target board to the host computer and it is turned on.

N o s

After the application has finished compiling, select Xilinx Tools > Program FPGA to open the
Program FPGA dialog box.
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8. In the Program FPGA dialog box, click Program.

Program FPGA |il
Program FPGA ‘?.;_.?',
Specify the bitstream and the ELF files that reside in BRAM memory

Hardware Configuration

Hardware Platform: lzynq _processor_system_wrapper_hw_platform_0 ']

Connection: lLDCE| '” MNew l

Device: Auto Detect
Bitstream: Zynq_processor_system_wrapper.bit lSearch...l lBerse..]

[] Partial Bitstream

EMM/MMI File: ZyNQ_processor_system_wrapper.mmi Search... | | Browse..

Software Configuration
Processor ELF/MEM File to Initialize in Block RAM

('—?j Program J [ Cancel

Figure 76: Program FPGA Dialog Box

9. Select and right-click the peri_test application in the Project Explorer, and select Debug As >
Debug Configurations.

The Debug Configurations dialog box opens.
10. Right-click Xilinx C/C++ application (System Debugger), and select New.
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@ Debug Configurations

Create, manage, and run configurations

Run or Debug a program using System Debugger.

% | =

i&i
4

type filter text

EA Performance Analysis
B Target Communication Framework

E Xilinx C/C++ application (GDB)

£ Xilinx C/C++ application (System Debugger on QEMU)
% Xilinx C/C++ application (5 [+ Ne

Du%cate

Delete

Filter matched 5 of 15 items

=

Configure launch settings from this dialog:

- Press the 'New' button to create a configuration of the selected type.
=| - Press the 'Duplicate’ button to copy the selected configuration.

¥ - Press the 'Delete’ button to remove the selected configuration.

*

% - Press the 'Filter’ button to configure filtering options.

+

- Edit or view an existing configuration by selecting it.

Configure launch perspective settings from the 'Perspectives’ preference page.

Close

Debug

Figure 77: Create New Debug Configuration

11. In the Create, manage, and run configurations screen, select the Target Setup tab and check the

Enable Cross triggering check box.
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12. Click Debug, as shown at the bottom of Figure 78.

Debug Configurations | 2@7‘
Create, manage, and run configurations -

Run or Debug a program using System Debugger.

e =
EIEE Name: peri_test Debug

type filter text @® Target Setup . (] Application| - Arguments| B§ Environment | 5 Symbol Files| > Source| & Path Map| = Common

EA Performance Analysis

8 Target Communication Framewark Debug Type: ’Standalone Application Debug ']

£, Xilinx C/C++ application (GDB) Connection: lmcal -]

£ Xilin C/C++ application (System Dekt
4 % Xilinx C/C++ application (System Dek

% peri_test Debug Hardware platform: [zynq_processor_system_wrapper_hw_pIaﬁorm_[) ']

Bitstream file: Zyng_processor_system_wrapper.bit lSearch‘..] [Browse‘..] [Generate‘..]

Initizlization file:  ps7_initicl
FPGA Device: Auto Detect
PS Device: Auto Detect

Summary of operations to be performed

["IReset entire system Following operations will be performed before launching the debugger. &
[C] Program FPGA 1. Run ps7_init. (Only first time after System reset or board power ON)
. 2. Run ps7_post_config. (Only first time after System reset or board power ON)

Run ps7_init 3. Run ps7_debug. 3

Run ps7_post_config 4. The following processors will be reset and suspended.

Enable Cross-Triggering 1) ps7_cortexad 0 —
5. All processars in the system will be suspended, and Applications will be downloaded to the following
processars as specified in the Applications tab. -

< | 11 3
Filter matched 6 of 16 items l Apply ] ’ Bevert ]
@) [ Debug ] [ Close l

Figure 78: Enable Cross-Triggering

The Confirm Perspective Switch dialog box opens.

13. Click Yes to confirm the perspective switch.
The Debug perspective window opens.

14. Set the terminal by selecting the SDK Terminal tab and clicking the |*. icon.
Use the following settings in Figure 79 for the ZC702 board and click OK.
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Connect to serial port 2%

Basic Settings
Port: COM3 -

Baud Rate: | 115200 v

~ Advance Settings

Data Bits: lS VI
Stop Bits: ll vl
Parity: lNDne VI
Flow Control: lNone vl

Timeout (sec):

oK ] l Cancel ]

Figure 79: Terminal Settings

15. Verify the Terminal connection by checking the status at the top of the tab as shown in Figure 80.
El Console v Tasks & SDK Terminal 22 [2! Problems 3 Executables w & L =0

Connected to: Serial { COM3, 115200,0,8)

Connected to COM3 at 115200

Clear

Figure 80: Verify Terminal Connection

16. If it is not already open, select . . /src/testperiph.c, and double click to open the source file.

17. Click the blue bar on the left side of the testperiph.c window as shown in the figure and select
Show Line Numbers.

18. Modify the source file by inserting a while statement at line 97.

19. In line 97, add while (1) above in front of the curly brace as shown in Figure 81.
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I3 system.hdf  |[jh system.mss [g *testperiph.c 2 = B

87 -

88 Status = ScuGicInterruptSetup(&intc, XPAR_PS7_SCUGIC © DEVICE ID);

89 if (Status == @) {

90 print("ScuGic Interrupt Setup PASSED\r\n");

o ) E

92 else { .

93 print("ScuGic Interrupt Setup FAILED\r\n");

94 }

95 }

96

97 while (1)

93 {

99 u3d2 status;

print("\r\nRunning GpioOutputExample() for axi gpio @...\r\n"};

Figure 81: Modify testperiph.c

20. Add a breakpoint in the code so that the processor stops code execution when the breakpoint is
encountered. To do so, scroll down to line 106 and double-click on the left pane, which adds a
breakpoint on that line of code, as it appears in Figure 82. Click Ctrl + S to save the file.
Alternatively, you can select File > Save.

o system.hdf  |[i, system.mss [¢ *testperiph.c &2 =
print("ScuGic Interrupt Setup FAILED\r\n"); -

}

while (1)
{

m

u32 status;

print("\r\nRunning GpioQOutputExample() for axi_gpio @...\r\n");
status = GpioOutputExample(XPAR AXI GPIO ©® DEVICE ID,4};

if (status == 0) {

print("GpioOutputExample PASSED.\r\n");
}

else { -

Figure 82: Set a Breakpoint

Now you are ready to execute the code from SDK.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 65
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=65

& XILINX

ALL PROGRAMMABLE. Lab 3: Zyng-7000 AP SoC Cross-Trigger Design

Step 8: Connect to Vivado Logic Analyzer

Connect to the ZC702 board using the Vivado Logic Analyzer.

1. In the Vivado IDE session, from the Program and Debug drop-down list of the Vivado Flow
Navigator, select Open Hardware Manager.

2. In the Hardware Manager window, click Open target > Open New Target.

Hardware Manager - unconnected

(i) Mo hardware target is open. Open target

Hardware E. Auto Connect

e =B & p»w Recent Targets 3

Mame Status

&  Open New T{eget...

Figure 83: Open a New Hardware Target

Note: You can also use the Auto Connect option to connect to the target hardware.
The Open New Hardware Target dialog box opens, shown in Figure 84.
3. Click Next.

-

=

¢ Open New Hardware Target

Open Hardware Target

VlWDO‘ This wizard will guide you through connecting to a hardware target.

To connect to a remote hardware target, provide the host name and IP port of the remote
machine on which the instance of a Vivado Hardware Server is running.

XILINX To connect to a remote hardware target, provide the host name and IP port of the remote
e TP AR L. machine on which the instance of a Vivado Hardware Server is running.

< Back Next = l [ Cancel

Figure 84: Open Hardware Target
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On the Hardware Server Settings page, ensure that the Connect to field is set to Local server
(target is on local machine) as shown in Figure 85.

4. Click Next.

¢ Open New Hardware Target | X |
Hardware Server Settings
Select local or remote hardware server, then configure the host name and port settings. Use Local server if ‘
the target is attached to the local machine; otherwise, use Remote server.

Connect to: | Local server (target is on local maching) -

Click Next to launch and/or connect to the hw_server (port 3121) application on the local machine.

Figure 85: Specify Server Name

5. On the Select Hardware Target page, click Next.

-

=

¢ Open New Hardware Target
Select Hardware Target
Select a hardware target from the list of available targets, then set the appropriate JTAG clock (TCK) ‘

frequency. If you do not see the expected devices, decrease the frequency or select a different target.
Hardware Targets

Type Name JTAG Clock Frequency

* xilinx_tcf [Digilent/210203342363A

Hardware Devices (for unknown devices, specify the Instruction Register (IR) length)
Name ID Code IR Length

& arm_dap_0 0BADD477 4
@ xc7z020_1 03727003 6

Hardware server: localhost:3121

< Back ” Next = FEinish

Figure 86: Select Hardware Target
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6. Ensure that all the settings are correct on the Open Hardware Target Summary dialog box, as

shown in Figure 87 and click Finish.

-

¢ Open New Hardware Target | X |
Open Hardware Target Summary
Vl\ADO (D) Hardware Server Settings:

o Server: localhost:3121

() Target Settings:
o Target: xilinx_tcf/Digilent/210203342363A
o Frequency: 15000000

e TP AR L. To connect to the hardware described above, click Finish
Next = Finish l [ Cancel

Figure 87: Open Hardware Target Summary

Step 9: Setting the Processor to Fabric Cross Trigger

When the Vivado Hardware Session successfully connects to the ZC702 board, you see the information

shown in Figure 88.

Hardware — O a =

AZSE R E

Name Status
Connected

=+ B localhost (1)
=@ e xilinx_tcf/Digilent/210203342363A (2) Open
@ arm_dap_0 (0) MfA
B xc7z020_1 (3) Programmed
& XADC (System Monitor)
3k hw_ila_1 (1LA4) O 1dle
5 hw_ila_2 (1LA) O 1dle

Figure 88: Vivado Hardware Window
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1. Select the ILA - hw_ila_1 tab and set the Trigger Mode Settings as follows:

e Set Trigger mode to TRIG_IN_ONLY
e Set TRIG_OUT mode to TRIG_IN_ONLY
e Under Capture Mode Settings, change Trigger position in

window to 512.

Lab 3: Zyng-7000 AP SoC Cross-Trigger Design

T hw_ila_1 x| ® hw_ila_2 X

Settings - hw_ila_1 — O = Status - hw_ila_1

Trigger Mode Settings * Core status
Trigger mode: TRIG_IMN_ONLY - M Tdle Pre-Trigger Waiting for Trigger
TRIG OUT mode: | TRIG_IN_ONLY - Capture status

Window 1 of 1

Idle Idle Idle

Capture Mode Settings
Capture mode: ALWAYS

Number of windows: 1

Trigger Setup - hw_ila_1 — O x

Window data depth: 1024 - [1 +

Trigger position in window: (512 [0 - 1023] Pressthe =k button to add probes
D

General Settings

® Refresh rate: |500 ms

Full

Fost-Trigger

‘Window sample 0 of 1024  Total sample 0 of 1024

Capture Setup - hw_ila_1

Figure 89: Set ILA Properties for hw_ila_1

2. Arm the ILA core by clicking the Run Trigger button Pl

This arms the ILA and you should see the status “Waiting for Trigger” as shown in Figure 90.

Hardware Manager - localhost/xilinx_tcf/Digilent/210203342363A
Hardware —Owv = S hw_ila_1 x| & hw ila_2 x
=1 o [ S| b
A== [E Bl b Settings - hw_ila_1 N Status - hw_ila_1
LT EEITD Trigger Mode Settings % ore status
=¥ localhost (1) Connected >l Ide
=@ xilinx_tcf/Digilent/2102033... Open Trigger mode: | TRIG_IN_ONLY hd M
arm_dap_0 NfA TRIG OUT mode: | TRIG_IN_ONLY - Capture status
=@ xc72020 Programmed Window 1 of 1
S XADC
5 0 100%
¢ hw_ila_2 (1A e Capture Mode Settings
Capture mode: ALwAYS Trigger Setup - hw_ila_1
Number of windows: 1
Window data depth: 1024 - |[1 +
Trigger position in window: |512 [0- 1023 ess the [dR] b
D, e bu
) T =) General Settings 7

Pre-Trigger

Waiting for Trigger Post-Trigger

Window sample 512 of 1024  Total sample 512 of 1024

50% 50%

— O % || Capture Setup - hw_ila_1

Full

Figure 90: Armed ILA Core
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3. Select the hw_ila_2 tab to set up trigger conditions to capture the trace, and set the Trigger Mode
Settings as follows:

e Set Trigger mode to BASIC_ONLY.
e Under Capture Mode Settings, change Trigger position in window to 512.
e With the hw_ila_2 tab selected, click on the + sign in the Trigger Setup window.

Trigger Setup - hw_ila_2 — O =

Press the mbl_lttcl'l to add probes

Figure 91: Add Probes to setup trigger

e Selectthe zyng processor system i/processing system7 0 TRIGGER OUT 0 TRIG
signal from the Debug Probes window under hw_ila_2 into the Trigger Setup window.

Add Probes b

Search:

& zyng_processor_system_ifaxi_gpio_0_GPIO_TRI_0O[3:0]

= zyng_processor_system_ifila_0_TRIG_OUT_ACK

= zyng_processor_system_ifila_0_TRIG_OUT_TRIG

= zyng_processor_system_ifprocessing_system7_0_TRIGGER_OUT_0_ACK
BN 7ynq_processor_system_ifprocessing_system7_0_TRIGGER_OUT_0_TRIG

’ DK ” Cancel

Figure 92: Add Probes window

4. Click OK.

5. In the Trigger Setup window, ensure that the Radix is set to [B] Binary and change the Value for the
zyng processor system i/processing system7 0 TRIGGER OUT 0 TRIG signal to 1.
This essentially sets up the ILA to trigger when the trig out transitions to a value of 1.
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Trigger Setup - hw_ila_2 — O =
Q Compare Value
+ [y —

Operator: | == (equal] -
D, _ o
Radix: [B] (Binary; w7
Value: 1 (logical one] -
4
Waveform - hw_ila_2 oK I | Cancel
<o I

Figure 93: Set Trigger Condition

6. Click OK.

7. Arm the ILA by clicking the Run Trigger button Pl'in the toolbar of the hw_ila_2 window. Just like
hw_ila_1, this ILA should be “armed” and waiting for the trigger condition to happen.

8. In SDK, in the Debug window, click the Resume button > in the SDK toolbar, until the code
execution reaches the breakpoint set on line 106 in the testperiph.c file.

9. Vivado displays the hw_ila_2 trigger as shown in Figure 94.

‘Waveform - hw ila 2 — 0o =

0_GPIO_TRI_O[3:0
IG_OUT_AC

a

£

7

i ¥ &£ 5

e

Figure 94: PS to PL Cross Trigger Waveform

Likewise, hw_ila_1 also triggers as seen in Figure 95.
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Figure 95: PS to PL Cross Trigger Waveform in hw_ila_1

This demonstrates that when the breakpoint is encountered during code execution, the PS7 triggers the
ILA that is set up to trigger. Between the two waveform windows, you can monitor the state of the
hardware at a certain point of code execution.

Step 10: Setting the Fabric to Processor Cross-Trigger

Now try the fabric to processor side of the cross-trigger mechanism. In other words, remove the
breakpoint that you set earlier on line 106 to have the ILA trigger the processor and stop code
execution. To do this:

1. Select the Breakpoints tab towards the top right corner of SDK window, right-click it, and uncheck
the testperiph.c [line: 106] checkbox. This removes the breakpoint that you set up earlier.

Note: Alternatively, you can select the breakpoint in line 106 of the testperiph.c file, right click and
select Disable Breakpoint.

2. In the Debug window, click Resume icon on the SDK toolbar. The code runs continuously because it
has an infinite loop.

You can see the code executing in the Terminal Window in SDK.

3. InVivado, select the hw_ila_1 tab. Change the Trigger Mode to BASIC_OR_TRIG_IN and the
TRIG_OUT mode to TRIGGER_OR_TRIG_IN.

4. Select the hw_ila_2 tab, and delete the existing probe in the Basic Trigger Setup window by selecting
it and clicking the Remove Selected Probe “-“ button to the left.

5. Click on the + sign in the Trigger Setup window to add the
zyng_processor system i/ila 0 TRIG OUT TRIG signal from the Add Probes window.

6. In the Basic Trigger Setup window, ensure that the Radix is set to [B] Binary and change the Value
for the zyng processor system i/ila 0 TRIG OUT_ TRIG signal to 1. This essentially sets
up the ILA to trigger when the trig_out transitions to a value of 1.
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7. Click the Run Trigger button Pl to “arm” the ILA. It moves into the "Waiting for Trigger”
condition.

8. Select the hw_ila_1 tab again and click the Run Trigger Immediate button " This triggers the
hw_ila_2 and the waveform window looks like Figure 96.

Waveform - hw_ila_2 _ O =

.._0_GPIO_TRI_O[3:0
0_TRIG_OUT_TRI
0_TRIG_OUT_AC|

... [RIGGER_OUT_0_ACK]

Figure 96: Waveform Demonstrating PS to PL Trigger

This also stops the Processor from executing code because the ILA triggers the TRIG OUT port,
which in turn interrupts the processor. This is seen in SDK the in the highlighted area of the debug
window.

% Debug =2
4t peri_test Debug (Local)

4l APU

4 ARM Cortex-A9 MPCore #0 (External Debug Request)
= 0x00102ef8 GpioOutputExample(): ../src/xgpio_tapp_example.c, line 226
= O0x00100600 main(): ./src/testperiph.c, line 103
= 0x0010dcTc _start(): xil-crtQ.S, line 128

4 ARM Cortex-A9 MPCore #1 (External Debug Request)

= Oxfffffelc
= 0x00000048
wc7z020

Figure 97: Verify that the Processor Has Been Interrupted in SDK
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Conclusion

This lab demonstrated how cross triggering works in a Zyng-7000 AP SoC processor based design. You
can use cross triggering to co-debug hardware and software in an integrated environment.

Lab Files

This tutorial demonstrates the cross-trigger feature of the Zyng-7000 AP SoC processor, which you
perform in the GUI environment. Therefore, the only Tcl file provided is 1ab3. tcl.

The 1ab3. tcl file helps you run all the steps all the way to exporting hardware for SDK.

You might need to modify the net names of the TRIG OUT ACK, TRIG OUT, TRIG IN, and
TRIG IN ACK signals in the tcl file as these net names might be different after synthesis. The debug
portion of the lab must be carried out in the GUL no Tcl files are provided for that purpose.
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Introduction

In this tutorial, you create a simple MicroBlaze™ system for a Kintex®-7 FPGA using Vivado® IP
integrator.

The MicroBlaze system includes native Xilinx® IP including:
e MicroBlaze processor
e AXI block RAM
e Double Data Rate 3 (DDR3) memory
e UARTLite
e GPIO
e Debug Module (MDM)
e Proc Sys Reset
e Local memory bus (LMB)

Parts of the block design are constructed using the Platform Board Flow feature. This lab also shows the
cross-trigger capability of the MicroBlaze processor. The feature is demonstrated using a software
application code developed in SDK in a stand-alone application mode.

This lab targets the Xilinx KC705 FPGA Evaluation Board.
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Step 1: Invoke the Vivado IDE and Create a Project

1.

© N o wu

Open the Vivado IDE by clicking the desktop icon or by typing vivado at a terminal command line.

From the Quick Start page, select Create New Project.

Quick Start
Vil pd |
=
| =
Create New Project Open Project Open Bxample Project
Tasks
| |2
Manage IP Open Hardware Manager Xilinx Tcl Store

Information Center

i

i

Documentation and Tutorials Quick Take Videos Release Notes Guide

Figure 98: Vivado Quick Start Page

The New Project wizard opens.

In the Project Name dialog box, type the project name and location. Make sure that Create project
subdirectory is checked. Click Next.

In the Project Type dialog box, select RTL Project. Click Next.

In the Add Sources dialog box, ensure that the Target language is set to VHDL or Verilog. Set the
Simulator language to Mixed.

Click Next.
In Add Existing IP dialog box, click Next.
In Add Constraints dialog box, click Next.

In the Default Part dialog box, select Boards and choose the Kintex-7 KC705 Evaluation Platform
along with the correct version. Click Next.

Review the project summary in the New Project Summary dialog box before clicking Finish to
create the project.

Because you selected the KC705 board when you created the Vivado IDE project, you see the
following message in the Tcl Console:

set property board part xilinx.com:kc705:part0:1.3 [current project]
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Although Tcl commands are available for many of the actions performed in the Vivado IDE, they are not
explained in this tutorial. Instead, a Tcl script is provided that can be used to recreate this entire project.
See the Tcl Console for more information. You can also refer to the Vivado Design Suit Tcl Command

Reference Guide (UG835) for additional information about Tcl commands.

Step 2: Create an IP Integrator Design

1. From Flow Navigator, under IP integrator, select Create Block Design.

The Create Block Design dialog box opens.

2. Specify the IP subsystem design name. For this step, you can use mb_subsystem as the Design
name. Leave the Directory field set to its default value of <Local to Project>.

3. Leave the Specify source set drop-down list set to its default value of Design Sources.

4. Click OK in the Create Block Design dialog box, shown in Figure 99.

¢ Create Block Design

Flease specify name of block design.

Design name: mb_subsystem

Directory: & <Local to Project>

Specify source set: | Design Sources

|z|

Figure 99: Name Block Design

5. IntheIP integrator diagram area, right-click and select Add IP.

The IP integrator Catalog opens. Alternatively, you can also select the Add IP icon in the middle of

the canvas.

Figure 100: Add IP
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6. As shown in Figure 101, type micr in the Search field to find the MicroBlaze IP, then select
MicroBlaze and press the Enter key.

Note: The IP Details window can be displayed by clicking CTRL+Q key on the keyboard.

1P Details x
Search: micr (3 matches)
: Name: MicroBlaze
MicroBlaze Debug Module (MDM) Version: 9.6
iF MicroBlaze MCS Interfaces: AXI4, AXI4-Stream

Description: The MicroBlaze 32 bit soft processor core,
providing an instruction set optimized for
embedded applications with many
user-configurable options. MicroBlaze has
many advanced architecture features like
Instruction and Data-side cache with AXI
interfaces, Floating-Point unit (FPU),
Memory Management Unit (MMU), and fault
tolerance support. It is highly recommended
to create MicroBlaze systems within Vivado
IP Integrator, to enable export to the Xilinx
Software Development Kit (SDK) for
software development.

Status: Production
License: Included
Change Log: View Change Lo

Vendor: Xilinx, Inc.
VLNV xilinx.com:ip:microblaze:9.6
Repository:  c:/Xilinx/Vivado/2016.1/data/ip

ENTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 101: Search Field

Use the Board Tab to Connect to Board Interfaces

There are several ways to use an existing interface in IP Integrator. Use the Board tab to instantiate
some of the interfaces that are present on the KC705 board.

1. Click the Board tab. You can see that there are several components listed in that tab. These
components are present on the KC705 board. These components are all listed under different
categories in the Board window.
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Fa
*

Board - O
A I SE]@ »*
@ Kintex-7 KC705 Evaluation Flatform

[=H& Clock Sources (0 out of 1 connected)

: LCr System differential clock

(= Ethernet Configurations (0 out of 4 connected)
-+ Onboard PHY
~¥2 PHY using SFP

-#2 PHY using SMA

~¥ PHY using SMA in LVDS mode
=M= External Memory (0 out of 3 connected)
-¥) DDR3 SDRAM
-+ Linear flash
~#_) SPI flash
[=H= General Purpose Input or Output (0 out of 5 connected)
~#) DIP switches
=¥ LCD

-+ Push buttons

~¥_) Rotary switch
=M= Miscellaneous (0 out of 2 connected)
,. c
L0 UART
EHE Reset (0 out of 1 connected)

-.C» FPGA Reset

£ Sources | E Design Signals-, & Board

Figure 102: Using the Board Part Interfaces to Configure a Memory IP

2. From the External Memory folder, drag and drop the DDR3 SDRAM component into the block
design canvas.

The Auto Connect dialog box opens, as shown in Figure 103, informing you that the Memory IP was
instantiated on the block design and then connected to DDR3 SDRAM component on the board.

-

¢ Auto Connect %

A new block 'mig_7series_0' was added to the block design and then connected
to board component 'DDR3 SDRAM'.

Figure 103: Auto-connect dialog box for DDR3

Note: The order of instantiation of these IP are important as they affect the options available with
Designer Assistance. As an example, when the DDR3 component is instantiated, the Block
Automation option for the MicroBlaze will enable caching by default.

3. Click OK.
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The block design looks like Figure 104.

mig_7series_0

DDR3 = Dddr3_sdram

(45X i clk t

. - ui_clk_sync_rs

sys_diff_clock D |l|4=sYs_cLk "
sys_rst "

mmem_locked
init_calib_complete

Memory Interface Generator (MIG 7 Series)

microblaze_0
|||<=INTERRUPT
5= Micro3laze .|
Clk IC aze M- ]]
Reset

MicroBlaze

Figure 104: Block Design After Instantiating the Memory IP Core

4. In the Board window, notice that the DDR3 SDRAM interface now is connected as shown by the
circle .

Board — 0O 1 x
Q= |'® pt %
H Kintex-7 KC705 Evaluation Platform

EHE Clock Sources (0 out of 1 connected)

L System differential clock

(== Ethernet Configurations (0 out of 4 connected)
-+ Onboard PHY
~¥J PHY using SFP
=¥ PHY using SMA
~#J PHY using SMA in LVDS mode
[=H= External Memory (1 out of 3 connected)
Bed0R3 SDRAM]
-+ Linear flash
~+#2) SPI flash

[=H= General Purpose Input or Qutout (0 out of 5 connectec ™
4| il =

| »

1

Figure 105: DDR3 Interface Shown Under Connected Interfaces

5. From the Board window, select UART under the miscellaneous folder and drag and drop it into the
block design canvas.

6. Click OK in the Auto Connect dialog box.
This instantiates the AXI Uartlite IP on the block design.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback l 80
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=80

& XILINX

ALL PROGRAMMABLE..

Lab 4: Using the Embedded MicroBlaze Processor

7. Likewise, from the Board window, select LED under the General Purpose Input or Output folder and
drag and drop it into the block design canvas.

8. Click OK in the Auto Connect dialog box.

This instantiates the GPIO IP on the block design and connects it to the on-board LEDs.

9. The block design now should look like Figure 106.

sys_diff_clock D

Memory Interface Generator (MIG 7 Series)

mig_7series_0

DDR34 |||
ui_dk_sync_rst
ui_dk
mmem_locked

D ddr3_sdram

init_calib_complete

microblaze 0

|||4=DEBUG
clk
Reset

|||4=INTERRUPT

Micro3laze ‘il

MicroBlaze
axi_gpio_0

] 3 led_8bits
—D rs232_uart

=R S_AXI
s axi_adk

P10 |||

-5 Axi_aresetn

AXI GPIO
axi_uartlite_0

i[5 a

UART
s axi_adk +

interrupt

-5 Axi_aresetn

AXT Uartlite

Figure 106: Block Design After Connecting the rs232_uart and the led_8bits Interfaces
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Add Peripheral: AXI BRAM Controller

1. Add the AXI BRAM Controller shown in Figure 107 by right-clicking on the IPI canvas and selecting
Add IP.

IP Details *

Search: axi bram (1 match)

Name: AXI BRAM Controller
Version: 4.0 (Rev. 7)
Interfaces: AXI4

Description: The AXI Block RAM (BRAM) Controller is a
soft IP core. The core is designed as an AXI
Endpoint slave IP for integration with the
AXI interconnect and system master devices
to communicate to local block RAM. The
core supports both single and burst
transactions to the block RAM and is
optimized for performance.

Status: Production

License: Included

Change Log: View Change Log

Vendor: Hilinx, Inc.

VLNV xilinx.com:ip:axi_bram_ctrl:4.0

ENTER to select, ESC to cancel, Ctrl+Q for IP details Repository:  c:/Xilinx/Vivado/2016.1/data/ip

Figure 107: Add BRAM Controller

Run Block Automation
1. Click Run Block Automation, displayed in Figure 108.

Z= Diagram X | B Address Editor x
#]| 4 mb_subsystermn

Q¢| (@ Designer Assistance available. Run Block Aytomation Run Connection Automation

.u'(

Figure 108: Run Block Automation

The Run Block Automation dialog box opens, as shown in Figure 109.

The values of the fields shown in this figure show the values that you will set in the next step.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 82
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=82

& XILINX

ALL PROGRAMMABLE, Lab 4: Using the Embedded MicroBlaze Processor

¢ Run Block Automation [ 53 |

Automatically make connections in your design by checking the boxes of the blocks to connect. Select a block on the left to display its
configuration options on the right. ‘

Q, —-. All Automation (1 out of 1 selected)

z O D

= MicroBlaze connection automation generates local memory of selected size, and

= caches can be configured. MicroBlaze Debug Module, Peripheral AXI interconnect,
Interrupt Controller, a clock source, Processor System Reset are also added and
connected as needed.

Description

Instance: /microblaze 0
Options
Local Memory: 64KB T
Local Memory ECC: | None ~
Cache Configuration: | 32KB ~
Debug Module: Bxtended Debug ~
Peripheral AXI Port: | Enabled ~
Interrupt Controller: [ |

Clock Connection: fmig_7series_0/ui_addn_clk_0 (100 MHz) =

0K ] [ Cancel

Figure 109: Run Block Automation Dialog Box

2. On the Run Block Automation page:

a. Set Local Memory to 64 KB.

b. Leave the Local Memory ECC to its default value of None.

¢. Change the Cache Configuration to 32 KB.

d. Change the Debug Module option to Extended Debug.

e. Leave the Peripheral AXI Port option set to its default value of Enabled.

f. Leave the Clock Connection option setto /mig 7series 0/ui addn clk 0 (100 MHz).
3. Click OK.

This generates a basic MicroBlaze system in the IP Integrator diagram area, shown in Figure 110.
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Figure 110: MicroBlaze System

Use Connection Automation

Run Connection Automation provides several options that you can select to make connections. This
section will walk you through the first connection, and then you will use the same procedure to make
the rest of the required connections for this tutorial.

1. Click Run Connection Automation as shown in Figure 111.

#| # mb_subsystem »

Oy | [ Designer Assistance available. Run Connection Automation

Figure 111: Run Connection Automation

The Run Connection Automation dialog box opens.
2. Check the interfaces in the left pane of the dialog box as shown in Figure 112.

Note: You will connect the MDM interfaces later.
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# Run Connection Automation

8

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to
display its configuration options on the right. ‘
@ [=Hm] All Automation (8 out of 10 selected)

E| ] £F axi_bram_ctrl_0

- i.[¥] i BRAM_PORTA

|| { BRAM_PORTE

- =l s_axa

E| [¥] £F axi_gpio_o

- L@ s_axa

E| [+] £F axi_uartlite_0

E‘Dg% Select an interface pin on the left panel to view its options
- =[] TRIG_IN_0

; 5----|:|4H+TRIG OUT_0

B iF mig_7series_0

i ¢4

= gys_rst
B.ﬁrst mig_7series_0_100M
----- V] = ext_reset_in

0K ] l Cancel

Figure 112: Run Connection Automation Dialog Box

Now, use the following table to set options in the Run Connection Automation dialog box
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Connection

More Information

Setting

axi_bram_ctrl_ 0

e BRAM_PORTA

The only option for this automation is to
instantiate a new Block Memory Generator as
shown under options.

axi_bram_ctrl_0

e BRAM_PORTB

The Run Connection Automation dialog box
opens and gives you two choices:

Instantiate a new BMG and connect the PORTB
of the AXI BRAM Controller to the new BMG IP
Use the previously instantiated BMG core and
automatically configure it to be a true dual-
ported memory and connected to PORTB of
the AXI BRAM Controller.

Leave the Blk_Mem_Gen option to
its default value of Blk_Mem_Gen
of BRAM_PORTA.

axi_bram_ctrl_ 0

Two options are presented in this case. The
Master field can be set for either cached or

The Run Connection Automation
dialog box offers to connect this to

The Clock Connection (for unconnected clks)
field is set to its default value of Auto.

e S AXI
non-cached accesses. the /microblaze_0 (Cached). Leave
it to its default value. In case,
cached accesses are not desired this
could be changed to /microblaze_0
(Periph).
Leave the Clock Connection (for
unconnected clks) field set to its
default value of Auto.
axi_gpio The Master field is set to /microblaze_0 Keep these default settings.
e SAX (Periph).

axi_uartlite_0

e S _AXI

The Master field is set to its default value of
/microblaze_0 (Periph).

The Clock Connection (for unconnected clks)
field is set to its default value of Auto.

Keep these default settings.

mig_7series_0

e S AXI

The Master field is set to /microblaze_0
(Cached). Leave it to this value so the accesses
to the DDR3 memory are cached accesses.

The Clock Connection (for unconnected clks)
field is set to its default value of Auto.

Keep these default settings.

mig_7series_0

e sys_rst

The board interface reset will be connected to
the reset pin of the Memory IP.

Keep the default setting.
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3. After setting the appropriate options as shown in the table above, click OK.

At this point, your IP integrator diagram area should look like Figure 113. The relative placement of
your IP might be slightly different.

Diagram ?— 0O« %

+[] 4, mb_subsystem »

| [@ Designer Assistance available. Run Connection Automation

ac

f‘\: iy _Tsexies 0

BeRHQ Wy H PG

Figure 113: MicroBlaze Connected to UART, GPIO and AXI Timer

Connect the Cross-Trigger pins of the MDM

1. Click on the Run Connection Automation link in the banner at the top of the block design canvas.
The Run Connection Automation dialog box opens.

2. Check the TRIG_IN_O interface under mdm_1. Click OK.
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¢ Run Connection Automation

£ |
Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its
configuration options on the right. ‘

@, =+H] All Automation (1 out of 3 selected) Description

Connection automation for Slave trigger interface /mdm_1/TRIG_IN_0 with a
Master trigger interface.

4k B4

Options

Slave: Mew ILA

l 0K ] ’ Cancel

Figure 114: Run Connection Automation to connect the TRIG_IN_O interface pin of the MDM

This instantiates an Integrated Logic Analyzer core in the block design and connects its TRIG_OUT

pin to the TRIG_IN_O interface pin of the MDM. In the next step, you will reuse this ILA to connect
the TRIG_OUT_O interface pin of the MDM.

3. Double click on the ila_0 instance to open the Re-customize IP dialog box. Check the Trigger In
Port option in the dialog box.
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1} Re-customize IP 83 |
ILA (Integrated Logic Analyzer) (6.1) ‘

i Documentation [ 1P Location

[ ] show disabled ports Component Name | mb_subsystem_ila_0_0

To configure more than 64 probe ports use Vivado Tcl Console

General Options | Monitor Interface0

Monitor Type

(C) Native (@) AXI

Number of Slots |1

Sample Data Depth | 1024 hd

[l TR1G N Same Mumber of Comparators for All Probe Ports

A|eR5LOT_0_AK TRIG_OUT || Mumber of Comparators |1 ¥
(3

Trigger Out Port
Trigger In Port
Input Pipe Stages 0 hd
Trigger And Storage Settings
["] capture Control

[] advanced Trigger

GUI configuration mode is limited to 64 probe ports.

[ OK ] I Cancel

Figure 115: Enable Trigger In Port by recustomizing the ILA

4. Click OK.
5. Click on the Run Connection Automation link at the top of block design canvas again.

6. In the Run Connection Automation dialog box select TRIG_OUT_0 interface under mdm_1. Leave the
Slave field set to /ila_0/TRIG_IN.
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¢ Run Connection Automation X

Automatically make connections in your design by checking the boxes of the interfaces to connect. Select an interface on the left to
display its configuration options on the right. ‘

Q=] All Automation (1 out of 2 selected)

- Description
= =[] £F mdm_1
= Connection automation for Master trigger interface /mdm_1,/TRIG_OUT_0 with
e - M_AxT N aute
= a Slave trigger interface.
IR IYTRIG_OUT 0
Options

Slave: | fila_0/TRIG_IN ~

E OK l [ Cancel

Figure 116: Run Connection Automation to connect the TRIG_OUT_0 interface pin of the MDM

7. Click OK.

8. To monitor the cross trigger pins in the ILA, you need to mark the nets connecting these pins for
debug. To do this, select the net connecting TRIG_OUT_0 interface pin of the MicroBlaze Debug
Module mdm_0 and the TRIG_IN interface pin of the ILA instance ila_0, right-click and select Mark
Debug from the context menu.

9. Likewise, select the net connecting interface pin TRIG_OUT of ila_0 and TRIG_IN_O interface pin of

mdm_1, right-click and select Mark Debug from the context menu. A tiny bug symbol L appears
on the nets marked for debug.

10. Next, connect the clk pin of ila_0 to ui_addn_clk_O pin of the mig_7series_0.

11. To monitor the AXI transactions taking place between the MicroBlaze and the GPIO, connect the net
connecting the interface pins MO1_AXI of the microblaze_0_axi_periph instance and the S_AXI
interface pin of the axi_gpio_0 instance, to the SLOT_0_AXI pin of the ILA instance, ila_0.

12. The Cross-Trigger interface connections should look as follows.
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axi_bram_ctrl 0 J axi_uartite_0
ek = UART |—|
s axi_ack it #l microblaze_0_axi_periph
5.ad_aresetn
A AM G . —— |k S00_aXI
AXI BRAM Contraller % Uartite .:Euc
. . Eﬁ.ﬂﬂk i ,
mig_7series_0 MOD_AXT= i
ﬁ _ARESETN [T Dmm% 5
ol DRI | 00 ACK gy '
lesvsax = s
1 o ok H0L_ACLK
" mmeom_lodked A0L_ARESETN
init_calib_complee -
_— AXD Interconnect
Memory Interface Generator {MIG 7 Series)
axi_apia_0 I |
£ dhs ot ; I
3_ack GO}
j i il mdm_1 —
pene 2 ||l4-meac w0 06| -
A_AKT_ACLE MBDEBUG (e ||| s 'E"'*-'j‘
{_AMI_ARESETN  TRIG_OUT 0dk |
= em—
MicroBlaze Debug Madule {MDM)
ila_0
|—i-l|4:=m¢uu 5
dRSIOT_ O AL TRIG_OUTHR ([}
ILA (Integrated Lagic Analyzer)

Figure 117: ILA connections to the Cross-Trigger Interface

13. Click the Regenerate Layout button % in the IP Integrator toolbar to generate an optimum layout
for the block design. The block diagram looks like Figure 118.
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Diagram —
#] & mb_subsystam »

Q¢ [& Designer Assistance available. Run Connection Automation

[s9

s W«E

i — ; MicroSiaze

o
I e

PeRSQR S G EH PR T E

Figure 118: Block Diagram After Regenerating the Layout

Step 3: Memory-Mapping the Peripherals in IP Integrator

1. Click the Address Editor tab. In the Address Editor:

[F5]
=

a. Expand the microblaze_0 instance by clicking on the Expand All icon in the toolbar to the
left of the Address Editor window.

b. Change the range of mig_7_series_0 IP in both the Data and the Instruction section to 512 MB,
as shown in Figure 119.
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B Address Editor X | %= Diagram X

A cell Slave Interface Base Name Offset Address Range  High Address
.
= [=+4F microblaze_0
= EI B Data (32 address bits : 4G)

= . mlcrublaze 0_local memurw’dlmh br... SLMB Mem 0x0000_0000 B4K 0x0000_FFFF
B mig_7series_0 S_AXI memaddr 0xB000_0000 512M 0x9FFF_FFFF

axi_uartlite_0 S AXI Reg Ox4060_0000 64K
w== gxi_gpio_0 5_AXI Reg 0x4000_0000 64K
. emm axi_bram_ctrl_0 S_AXI Mem0 0xC000_0000 8K
(=B Instruction (32 address bits : 4G)

Ox4080_FFFF
0x4000_FFFF
0xCO00_1FFF

4 4 4 4 4

== microblaze_0_local_memory/ilmb_bra... SLMB Mem 0x0000_0000 64K ~ 0x0000_FFFF
memaddr |oxéoo0 cooo TR |
“em gxi_bram_ctrl 0 5_AXI Mem0 0xC000_0000 32M | 0xCO00_LFEF
Elﬁ mdm_1 64M
(=+H Data (32 address bits : 4G) 128M
~~=m microblaze_0_local_memory/dimb_br... SLMB1 Mem 0x0000_0000 256M 0x0000_FFFF
1G |
2G =
4G

Figure 119: Data and Instruction Set to 512 MB

You must also ensure that the memory in which you are going to run and store your software is
within the cacheable address range. This occurs when you enable Instruction Cache and Data Cache,
while running the Block Automation for the MicroBlaze processor.

To use either Memory IP DDR or AXI block RAM, those IP must be in the cacheable area; otherwise,
the MicroBlaze processor cannot read from or write to them.

You can also use this map to manually include or exclude IP from the cacheable region or otherwise
specify their addresses. The following step demonstrates how to set the cacheable region.

2. Double click on the MicroBlaze in the block design to re-configure it. Go to the Cache page (page 3)
of the Re-customize IP dialog box, as shown in Figure 120. On this page, for both the Instruction
Cache and Data Cache:

a. The Size in Bytes option should be set to 32 kB. Leave it set to this value.
b. Set the Line length option to 8.

3. Set the Base Address to 0x80000000 by clicking on the Auto button so that it changes to Manual,
which enables the Base Address field.

4. Set the High Address to OXFFFFFFFF by clicking on the Auto button so that it changes to Manual,
which enables the High Address field.

5. Enable Use Cache for All Memory Accesses for both caches by clicking the Auto button first to
change it to Manual, and then checking the check box.

6. Next, verify that the size of the cacheable segment of memory (that is, the memory space between
the Base and High addresses of the Instruction Cache and Data Cache) is a power of 2, which it
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should be if the options were set as specified. Additionally, ensure that the Base address and the
High address of both Data Cache and Instruction Cache are the same.

7. Ensure that all IP that are slaves of the Instruction Cache, and that the Data Cache buses fall within
this cacheable segment. Otherwise, the MicroBlaze processor cannot access those IP.

Note: For any IP connected only to the Instruction Cache and Data Cache bus, you must enable the
Use Cache for All Memory Access option. In this example, the Instruction Cache and Data Cache
buses are the sole masters of DDR and block RAM; therefore, you must enable this option. In other
configurations, you must decide whether to enable this option per the design requirements.

1F Re-customize IP

=]
MicroBlaze (9.6) ‘
il Documentation [ TP Location #% Advanced
IP Symbal” Resources Component Name  mb_subsystem_microblaze_0_0

Frequency Cache
B Area
I Performance Enable Instruction Cache Enable Data Cache

Resource Estimates Instruction Cache Feature Data Cache Feature
Size in Bytes 32kB M Size in Bytes 32kB

100.0 Line Length 8 hd Line Length 8

a0.0 @FT™TL) sase Address |0xe0000000 @FTTIL) sase Address |0x0000000080000000

0o @FTTTL) High Address | 0xFFRFFFFF @FTTIL) High Address | 0x00000000FFFFFFFF

Enable Writes Enable Writes

70.0
= ﬂ_\‘ Use Cache for All Memory Accesses ﬂ_) Use Cache for All Memory Accesses
— 60.0
@ Use Distributed RAM for Tags Use Distributed RAM for Tags
5 500
o

m@d Data Width 32-bit hd Data Width 32-bit

Number of Streams o M || Enable Write-back Storage Policy
g Number of Victims 0 -
Number of Victims 0

20,07

Resource Usage

BRAM: DSP48E:
20 1
Figure 120: Setting Cache option for MicroBlaze
8. Click OK.
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Step 4: Validate Block Design

To run design rule checks on the design:

1. Click the Validate Design button | on the toolbar, or select Tools > Validate Design.

2. The Validate Design dialog box informs you that there are no critical warnings or errors in the

design. Click OK.

3. Save your design by pressing Ctrl+S, or select File > Save Block Design.

Step 5: Generate Output Products

1. In the Sources window, select the block design, then right-click it and select Generate Output

Products. Alternatively, you can click Generate Block Design in the Flow Navigator.

The Generate Output Products dialog box opens.

2. Click Generate.

¢ Generate Output Products £

The following output products will be generated.

Preview
Q| Eh4i mb_subsystem.bd (Global)
& _'| Synthesis

2 ]
g H .
g [l Implementation

2 :

L H
e “-[ I Simulation

Synthesis Options
@) Global
QOut of context per IP
Out of context per Block Design

Run Settings

Mumber of jobs:|4 -

Generate ” Cancel

Figure 121: Generate Output Dialog Box

3. Click OK in the Generate Output Products dialog box.
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Step 6: Create a Top-Level Verilog Wrapper

1. Under Design Sources, right-click the block design mb_subsystem and click Create HDL Wrapper.

2. In the Create HDL Wrapper dialog box, Let Vivado manage wrapper and auto-update is selected
by default.

3. Click OK.
¢ Create HDL Wrapper [ 3|
You can either add or copy the HDL wrapper file to the project. Use copy option if you
wiould like to modify this file. ‘
Options

(") Copy generated wrapper to allow user edits

(@) Let Vivado manage wrapper and auto-update

@ OK l I Cancel

Figure 122: Creating an HDL Wrapper
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Step 7: Synthesize the design

1. From the Flow Navigator, click on Run Synthesis.

2. After synthesis finishes, open the synthesized design by selecting the Open Synthesized Design
option in the Synthesis Completed dialog box.

Synthesis Completed b

':0] Synthesis successfully completed.
Next
Run Implementation

@) Open Synthesized Design

View Reports

Don't show this dialog again

0K ] | Cancel

Figure 123: Synthesis Completed dialog box

3. Click OK.

Step 8: Insert an Integrated Logic Analyzer (ILA) Core

When the synthesized design schematic opens, the Debug window also opens. In the Debug window,
notice that there is one ILA, i1a 0, that has already been inserted in the design. This ILA was
instantiated in the block design and will monitor the AXI transactions to the GPIO. You will insert
another ILA in the design to monitor the activity on cross-trigger signals.
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Debug — 0O a X
A Name Driver Cell
=
"f =4 dbg_hub (labtools_xsdbm_v1)

&4 || B ila_0 (labtools_ila_vs)
E]|| O Unassigned Debug Mets (0}
=¥
et
e

Debug Cores | Debug Mets

Figure 124: Unassigned Debug Nets

1. From the Vivado main menu, select Tools > Set up Debug.
Alternatively, from the left side of the Debug window, click the Set up Debug button .

The Set up Debug dialog box opens, shown in Figure 125.
2. Click Next.

-

¢ SetUp Debug X

Set Up Debug

Vl\/ADO‘ This wizard will guide you through the process of

1. Choosing nets and connecting them to debug cores.

2. Associating a clock domain with each of the nets chosen for debug.

3. Choosing additional features on the debug cores like Data Depth, Advanced Trigger
mode and Capture Control.

Note: This setup wizard does not apply to the VIO, IBERT or JTAG-to-AXI-Master debug
cores. Please refer to Vivado Design Suite User Guide: Programming and Debugging
(UG908) for further instructions on how to use these IPs.

XILINX

e TP AR L. To continue, click Next

Figure 125: Set Up Debug Dialog Box

3. In the Nets to Debug page, click the Find Nets to Add button at the bottom of the dialog box.
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¢ Set Up Debug
Nets to Debug

The nets below will be debugged with ILA cores. To add nets click "Find Mets to Add". You can also select ‘
nets in the Netlist or other windows, then drag them to the list or click "Add Selected Nets".

=

7 Drag and drop nets from Metlist View , Find Results, or use Find Nets to Add

[ Find Mets to Add... Nets to debug: 0

Figure 126: Add Nets to Debug

4. In the find Nets dialog box (Figure 127), change the Properties to select MARK_DEBUG from the
first drop-down list. This will show all the nets that have the MARK DEBUG attribute set.

¢ Find Nets | 3 |
Find objects in the current design or device by filtering Tcl properties and objects. ‘
Properties
MARK_DEBUG - [|is *|(true - |+

[] Regular expression Search hierarchically Display unique nets

Of objects: B

Command: show_objects -name NET_ONLY [get_nets -hierarchical -top_net_of_hierarchical_group -filter { MARK_DEBUG == "TRUE" } ]

[ DK H Cancel ]

Figure 127: Find Nets with MARK_DEBUG Attribute

5. Click OK.
The Add Nets to Debug dialog box opens.
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6. Select the following nets, as shown in Figure 128:
e mb_subsystem_i/ila_0_TRIG_OUT_ACK
e mb_subsystem_i /ila_O_TRIG_OUT_TRIG
e mb_subsystem_i /mdm_1_TRIG_OUT_0_ACK
e mb_subsystem_i /mdm_1_TRIG_OUT_0_TRIG

-

#- Add Nets to Debug =]

Select the nets you want to add.

Q, - mb_subsystem_i/microblaze_0_axi_periph_M01_AXI ARADDR (2) =
Z -7 mb_subsystem_i/microblaze_0_axi_periph_M01_AXI WDATA (32)

g [+-I7i3 mb_subsystem_i/microblaze_0_axi_periph_M01_AX]_ WSTRB (4)
-

1

----- ' mb_subsystem_i/microblaze_0_axi_periph_M01_AXI ARREADY
----- % mb_subsystem_i/microblaze_0_axi_periph_M01_AXT ARVALID
----- % mb_subsystem_i/microblaze_0_axi_periph_M01_AXI AWREADY 4

Ci% b auboadone ifoniocabhlama A oaed oociob KOO A%WT  S180F81 T @

Figure 128: Add Nets Connected to Cross-Trigger Pins

7. Click OK.

The additional cross-trigger nets are added to a new ILA in the Set Up Debug dialog box.

8. In the Set Up Debug dialog box select all the newly added nets, right-click and select Select Clock
Domain.
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¢ SetUp Debug -

Nets to Debug
The nets below will be debugged with ILA cores. To add nets click "Find Mets to Add". You can also select ‘
nets in the Metlist or other windows, then drag them to the list or click "Add Selected Mets".
| Name  Clock Domain Driver Cell  Probe Type
=
i mb_subsystem_i/mdm_1/U0/Dbg_Update_0 LUTE

= mb_subsystem_i/mdm_1/U0/Ext_JTAG_DRCK
i Seleq, Clock Domain...

123
== Remove Nets

Set Probe Type 3
Export to Spreadsheet...

| Find Nets to Add... Nets to debug: 4

<Back | mNext> | mnish

Figure 129: Select Clock Domain for the newly added nets

9. Select the
mb_subsystem/mig 7seris 0/u mb subsysterm mig 7series 0 0 mig/u ddr3 infr

astructure/ui addn clk 0 clock as the Clock Doman for all the cross-trigger signals.

¢ Select Clock Domain @
The list below contains 'GLOBAL_CLOCK' nets.
To see other types of clock nets use the drop-down button. ‘

= = GLOBAL_CLOCK ¥ | [¥] Search hierarchically

----- || mb_subsystem_ifmig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/ui_addn_clk_0
---- Il mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/CLK

----- Il mb_subsystem_ifmdm_1/Ud/Ext_JTAG_DRCK

----- Ml mb_subsystem_i/mdm_1/U0/Dbg_Update_0

----- Il mb_subsystem_ifmig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/mmecm_ps_clk
----- Il mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_iodelay_ctrl/CLK

---- Tl mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/gen_ui_sxtra_clocks.u_bufg_clk_div2_n_
----- [l mb_subsystem_ifmig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/ui_addn_clk_1

----- Il mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/ui_addn_clk_2

----- Il mb_subsystem_ifmig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/ui_addn_clk_3

----- Il mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_ddr3_infrastructure/ui_addn_clk_4

---- Tl mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mig/u_iodelay_ctrl/clk_ref_300_400_en.clk_ref_400.u_bufg_clk_ref
4 1} ] r

ok || cancel

Figure 130: Select the appropriate clock for the newly added cross-trigger signals
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10. Click OK.
11. Click Next on the Nets to Debug page of the Set Up Debug wizard.

-

¢ SetUp Debug

Nets to Debug

The nets below will be debugged with ILA cores. To add nets click "Find Mets to Add". You can also select
nets in the Metlist or other windows, then drag them to the list or click "Add Selected Mets".

(]
¥

| Name  Clock Domain Driver Cell  Probe Type
=

g mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mi...|LUT&
= mb_subsystem_i/mig_7series_0/u_mb_subsystem_mig_7series_0_0_mi...|FDRE
E mb_subsystem_i/mig_7series 0/u_mb_subsystem_mig_7series_0_0_mi...|FDRE
= : LUTS
s

1

+

| Find Nets to Add... Nets to debug: 4

<Back | Next> | Finish

Cancel

Figure 131: Specify Nets for Debugging

12. The ILA (Integrated Logic Analyzer) Core Options dialog box opens, as shown in Figure 132.

-

¢ SetUp Debug @

ILA Core Options
Choose features for the ILA debug cores. ‘

Sample of data depth:
Input pipe stages:

Trigger and Storage Settings
Capture control
Advanced trigger

<Back | Next> | Finish Cancel

Figure 132: Enable Advanced Trigger and Capture Modes
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13. In the ILA (Integrated Logic Analyzer) Core Options page, do the following:
a. Leave Sample of Data Depth and Input Pipe Stages default values of 1024 and 0.
b. Select both Capture Control and Advanced Trigger check boxes.
c. Click Next.
14. In the Set up Debug Summary page verify that the debug core was added and click Finish.

-

=

¢ SetUp Debug

Set up Debug Summary

Jy
Vl\/ADO (D 0 debug cores will be removed

(D)1 debug core will be created

(i) Found 1 clock

XILINX Open in Debug layout

L iy To apply the above changes, click Finish

E Next = Finish l[ Cancel

Figure 133: Set up Debug Summary page

The debug nets are now assigned to the ILA u_ila 0 debug core, as shown in Figure 134. Notice
that a new ILA called u_ila_0 has been added.

Debug — 0O a X
A MName Driver Cell
=
= [—-4& dbg_hub (labtools_xsdbm_v1)
=] (-5 ila_0 (labtools_ila_vs)
=-4F u_ila_0 (labtools_ila_vs)
e e i (1)
- & probe0 (1)
i% [+&# probel (1)
ok & probe2 (1)

o [+&# probe3 (1)
% | = Unassigned Debug Mets (0

Debug Cores | Debug Nets

Figure 134: Debug Nets Assigned to Debug Core
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Step 9: Take the Design through Implementation

In the Flow Navigator:
1. Click Generate Bitstream.

The Save Project dialog box opens.
2. Click Save.

3. The Out of Date Design dialog box opens informing that synthesis may go out-of-date as the
constraints related to ILA were saved.

4. Click OK.

5. The No Implementation Results Available dialog box asks if synthesis and implementation can be
launched before generating bitstream.

6. Click Yes.

Bitstream generation can take several minutes to complete. Once it finishes, the Bitstream
Generation Completed dialog box asks you to select what to do next.

7. Keep the default selection of Open Implemented Design and click OK.

8. The Vivado dialog box opens and asks you if you want to close the Synthesized Design before
opening the Implemented Design.

9. Click Yes.

10. Verify that all timing constraints have been met by looking at the Timing - Timing Summary
window, as shown in Figure 135.

Timing - Timing Summary - impl_1 ?— 0O & ®
QA TE e ? 4 Design Timing Summary

(i) Thisisa saved report x| Setup Hold Pulse Width

?r’n:::as‘:::‘irg’;‘atm” = Worst Megative Slack (WNS): 0.070 ns Worst Hold Slack (WHS):  0.024 ns Worst Pulse Width Slack (WPWS): 0.062 ns

H | Total Negative Slack (TNS):  0.000 ns Total Hold Slack (THS): 0.000 ns Total Pulse Width Negative Slack (TPWS): 0.000 ns
~Clock Summary (53) - Number of Failing Endpoints: 0 Number of Failing Endpoints: 0 Number of Failing Endpoints: 0

+J) Check Timing (20) Total Number of Endpoints: 90810 Total Number of Endpoints: 90810 Total Number of Endpoints: 37226
] Intra-Clock Paths
- Inter-Clock Paths
+-Other Path Grouns S
Timing Summary - impl_1 4B

All user specified timing constraints are met.

Figure 135: Timing Summary
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Step 10: Exporting the Design to SDK

Next, open the design and export to SDK.
1. Select File > Export > Export Hardware.

2. In the Export to Hardware dialog box, select the Include bitstream check box, shown in Figure 136.
Make sure that the Export to field is set to <Local to Project>.

¢ Export Hardware o3

Export hardware platform for software
development tools ‘

[#] Include bitstream

Export to: |5 <Local to Project> -

0K ] [ Cancel

Figure 136: Export to Hardware Dialog Box

3. Click OK.

4. Select File > Launch SDK. In the Launch SDK dialog box, make sure that both the Exported
location and the Workspace drop-down lists are set to <Local to Project>.

¢ Launch SDK [ 23

y

Launch software development tool.

Exported location: | &) <Local to Project> -

Workspace: | &1 <Local to Project> -

0K l I Cancel

Figure 137: Launch SDK Dialog Box

5. Click OK.

SDK launches in a separate window.
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Step 11: Create a “Peripheral Test” Application

1. In SDK, right-click mb_subsystem_wrapper_hw_platform_0 in the Project Explorer and select New
> Project, as shown in Figure 138.

@ C/C++ - mb_subsystem_wrapper_hw_platform_0/system.hdf - Xilinx SDK
File Edit Source Refactor Navigate Search Run Project Xilinx Tools Window Help
il | B@~ @@ dvr@~y FvO-Q~ %W B 2EHE & =5~

[+ Project Explorer &3 0% | ¥ ¥ < O|Gsystemhdf 2

4 3 mb_subsystem_wrapper_hw_pl** a = =
[ system.hdf New L i Prﬁ;ect...
Go Into % File
Figure 138: SDK New Project Selection
2. Inthe New Project dialog box, select Xilinx > Application Project.
= @ =]

New Project

Select a wizard

Wizards:

type filter text

> = General
C = CfC++
4 (= Xilinx
& Application Project
W, Board Support Package
57 Hardware Platform Specification

Figure 139: SDK New Project Wizard
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3. Click Next.

4. Type a name (such as peri test) for your project and choose standalone as the OS platform, as

displayed below in Figure 140.

-

@ New Project o | &)%)
Application Project ,.-f
Create a managed make application project.
Project name: peri_test
Use default location
CAtutorialsh\2016.1\UG940\ lab4\ lab4.sdk\peri_test Browse...
default -
OS Platform: lstanclalone v]
Target Hardware
Hardware Platform: [mb_subsystem_wrapper_hw_platform_[} vl [New...]
Processor: [microblaze_[} - l
Target Software
Language: @C O C++
32-bit -
Board Support Package: (@ Create New  peri_test_bsp
Use existing -
@' < Back " Mext = l [ Finish ] [ Cancel

Figure 140: New Project: Application Project Wizard

5. Click Next.
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6. Select the Peripheral Tests application template, and click Finish.

-

New Project ?@

Templates ,.E
Create one of the available templates to generate a fully-functioning application
project.

Available Templates:

Dhrystone Simple test routines for all peripherals in the =
Empty Application hardware.

Hello World

IwIP Echo Server

Memory Tests

Peripheral Tests
SREC Bootloader

SREC SPI Bootloader

@ MNext = Finish ] [ Cancel

Figure 141: New Project: Template Wizard

SDK creates a new “peri_test” application.

7. Right-click the peri test application in the Project Explorer and select Generate Linker Script.

The Generate Linker Script dialog box opens.
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8. Select the Advanced tab and change the Assigned Memory for Heap and Stack to mig_7series_0.
To do this:
a. Inthe Basic tab, change the Place Code Sections in to mig_7_series_0 using the drop-down list.

b. Likewise, change the Place Data Sections in and Place Heap and Stack in to mig_7series_0.

m Generate a linker script P
Generate linker script
Control your application’s memory map.
Output Settings Basic | Advanced
Project: peri_test ] ) - -
: Place Code Sections in:  mig_7series_0 -
Qutput Script:
itorials\2015.3\UG940\lab4\lab4.sdK\peri_test\sr Place Data Sectionsin:  mig_7series 0 v
Modify project build settings as follows: Place Heap and Stack in: | mig_7series 0 v
Set generated script on all project build configurations VI Heap Size: 1KB
Stack Size: 1KB

Hardware Memory Map

Memaory Base Address Size
axi_bram_ctrl_0_S_AXI_BAS.. 0xC0000000 8KB
microblaze_0_local_memor.. Ox00000000 64 ..
mig_7series_0 0x80000000 512..

» Fixed Section Assignments

@j Generate J l Cancel

Figure 142: Basic Tab of the Generate a linker script dialog box

¢. The Advanced options all change to mig_7_series_0 as shown below.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 109
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=109

& XILINX

ALL PROGRAMMABLE.

Lab 4: Using the Embedded MicroBlaze Processor

Generate a linker script Py
Generate linker script
Control your application's memory map.
Cutput Settings Advanced
FIEIEEE TErLE Code Section Assignments
Output Script: Secti Acsianed M c ed S
ection ssigned Memory ompiled S...
Jtorials\2015.3\UG40\ Iab4\|ab4 sdk\peri_test\sre\lscrip o mig.Tseries.0 0 bytes
Modify project build settings as follows:
Add Section | | Remove Section
Set generated script on all project build configurations '] :
Hardware Memory Map Data Section Assignments
Memory Base Address Size Section Assigned Memory Compiled S...
axi_bram_ctrl_0_S_AXI BAS.. 0xC0000000 8 KB rodata mig_/series 0 0 bytes
microblaze_0_local_memor.. 0x00000000 64 .. sdataZ mig_7series 0 0 bytes
mig_7series_0 0x80000000  512.. sbss2 mig_7series 0 0 bytes
data mig_7series 0 0 bytes
sdata mig_7series_0 0 bytes
shss mig_7series_0 0 bytes
bss mig_7series 0 0 bytes
Heap and Stack Section Assignments
» Fixed Section Assignments Section Assigned Memory Assigned Si... *
heap mig_7series 0 1KB -
< | 1 3
@j Generate J l Cancel

Figure 143: Generate Linker Script Dialog Box

Setting these values tomig 7series 0 ensures that the compiled code executes from the

Memory IP.
9. Click Generate.

10. Click Yes to overwrite it in the Linker Script Already Exists! dialog box.

Step 12: Executing the Software Application on a KC705

Board

Make sure that you have connected the target board to the host computer and it is turned on.

1. Select Xilinx Tools > Program FPGA to open the Program FPGA dialog box.
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2. In the Program FPGA dialog box, click Program, as shown in Figure 144.

Lab 4: Using the Embedded MicroBlaze Processor

-

@ Program FPGA

Program FPGA
Specify the bitstream and the ELF files that reside in BRAM memaory

Hardware Configuration

)

Hardware Platform: [mb_subsystem_wrapper_hw _platform_0

8

Connection:
Device:

Bitstream:
[ Partial Bitstream
BEMM/MMI File:

Software Configurati

Processor
microblaze 0

7

[Local

[ |

Auto Detect

mb_subsystem_wrapper.bit

mb_subsystem_wrapper.mmi

on
ELF/MEM File to Initialize in Block RAM
bootloop

lSearch...l lBerse..]

lSearch...l lBerse..]

Program

||

Cancel

Figure 144: Program FPGA Dialog Box

3. Select and right-click the peri_test application in the Project Explorer, and select Debug As >

Debug Configurations.

The Debug Configurations dialog box opens.
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4. Right-click Xilinx C/C++ application (System Debugger), and select New.

@ Debug Configurations

Create, manage, and run configurations

Run or Debug a program using System Debugger.

b | S Configure launch settings from this dialog:
type filter text - Press the 'New' button to create a configuration of the selected type.
k= Performance Analysis = - Press the 'Duplicate’ button to copy the selected configuration.

B Target Communication Framework
E Xilinx C/C++ application (GDB)
£ Xilinx C/C++ application (System Debugger on QEMU) || 3¢ - Press the ‘Filter’ button to configure filtering options.

¥ - Press the 'Delete’ button to remove the selected configuration.

dk

%& Xilinx C/C++ application (S Ne& - Edit or view an existing configuration by selecting it.
Duphicate
Delete Configure launch perspective settings from the 'Perspectives’ preference page.

Filter matched 5 of 15 items

o —~
@ Debug Close

Figure 145: Create New Debug Configuration
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5. Click Debug.

Lab 4: Using the Embedded MicroBlaze Processor

m Debug Configurations

Create, manage, and run configurations

Run or Debug a program using System Debugger.

CEX B~
type filter text
[ pPerformance Analysis
[E Target Communication Framework
£ Xilinx C/C++ application (GDB)
£ Xilinx C/C++ application (System Debugger on QEMU)
£ Xilinx C/C++ application (System Debugger)
. peri_test Debug

S

L

Name: peri_test Debug

® Target Setup . [[] Application| ¢+ Arguments| B8 Environment| 5 Symbol Files| %~ Source| & Path Map = Common

Debug Type: IStandaIcneApplicaticn Debug ']

) [ew]

Connection: lLucaI

Hardware platform: [mb,subsystem,wrapper,hWJlarform,D ']

Bitstream file:

download.bit

Search... | | Browse...

Search...
FPGA Device: Auto Detect
Auto Detect Select...
Summary of operations to be performed
["/ Reset entire system Following operations will be performed before launching the debugger. -

1. The following processors will be reset and suspended.

1) microblaze_0
2. All processors in the system will be suspended, and Applications will be downloaded to the
following processors as specified in the Applications tab.

1) microblaze_0

Program FPGA
Run ps7_init
Run ps7_post_config
Enable Cross-Triggering

Apply Revert

Filter matched 6 of 16 items

@) Debug l l Close

Figure 146: Debug Configurations dialog box

The Confirm Perspective Switch dialog box opens.

6. Click Yes to confirm the perspective switch.

The Debug perspective window opens.
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7. Set the terminal by selecting the SDK Terminal tab and clicking the %/ icon.
8. Use the settings shown in Figure 147 for the KC705 board and click OK.

Connect to serial port P

Basic Settings

Port: COM3 -
Baud Rate: 9600 -
~ Advance Settings

Data Bits: lB vl
Stop Bits: ll VI
Parity: lNone vl
Flow Contral: lNDne VI
Timeout (sec): 5
OK ] l Cancel ]

Figure 147: Terminal Settings

9. Verify the Terminal connection by checking the status at the top of the tab as shown in Figure 148.

El Console | ¥ Tasks | & SDK Terminal 52 | [2{ Problems| 3 Executables| @ Memory

Connected to: Serial { COM3, 9600, 0, 8)

Connected to COM3 at 9600

Figure 148: Verify Terminal Connection

10. If it is not already open, select . ./src/testperiph.c, and double click to open the source file.

Embedded Processor Hardware Design www.xilinx.com | Send Feedback I 114

UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=114

& XILINX

ALL PROGRAMMABLE, Lab 4: Using the Embedded MicroBlaze Processor

11. Modify the source file by inserting a while statement at line 41.

a. Click the blue bar on the left side of the testperiph.c window as shown in the figure and
select Show Line Numbers.

b. Inline 41, add while (1) above in front of the curly brace as shown in Figure 149.

1t system.hdf [l system.mss ¢ *testperiph.c

8 Xil DCacheEnable(};
print("---Entering main---\n\r");

while (1)
{
u32 status;

print("\r\nRunning GpiocOutputExample() for axi gpio @...\r\n"};
status = GpioOutputExample(XPAR_AXI GPIO @ DEVICE ID,8);

if (status == 8) {
print("GpioOutputExample PASSED.\r\n");
}
else {
print("GpioOutputExample FAILED.\r\n");

Figure 149: Modify testperiph.c

12. Add a breakpoint in the code so that the processor stops code execution when the breakpoint is
encountered. To do so, scroll down to line 50 and double-click on the left pane, which adds a
breakpoint on that line of code, as shown in Figure 150. Click Ctrl + S to save the file. Alternatively,
you can select File > Save.
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¢ system.hdf [, system.mss [¢] *testperiph.c &2
38 Xil DCacheEnable();
39 print("---Entering main---\n\r");
40
41 while (1)
42 {
43 u3d2 status;
44
45 print("\r\nRunning GpioOutputExample() for axi_gpio @...\r\n");
46
47 status = GpioOutputExample(XPAR_AXI GPIO @ DEVICE ID,8);
48
49 if (status == @) {
50 print("GpioOutputExample PASSED.\r\n");
51 }
52 else {
53 print("GpioOutputExample FAILED.\r\n");
4

Figure 150: Set a Breakpoint

Now you are ready to execute the code from SDK.

Step 13: Connect to Vivado Logic Analyzer

Connect to the KC705 board using the Vivado Logic Analyzer.

1. In the Vivado IDE session, from the Program and Debug drop-down list of the Vivado Flow

Navigator, select Open Hardware Manager.

2. In the Hardware Manager window, click Open target > Open New Target.

Hardware Manager - unconnected

(i) Mo hardware target is open. Open target

Hardware Q Auto Connect

o = Q Q Pl M Recent Targets »

Mame Status

&  Open New T{eget...

Figure 151: Open a New Hardware Target

Note: You can also use the Auto Connect option to connect to the target hardware.

The Open New Hardware Target dialog box opens.

3. Click Next.
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¢ Open New Hardware Target

=

Open Hardware Target

[
VlVADO This wizard will guide you through connecting to a hardware target.

HiLx Editions
To connect to a remote hardware target, provide the host name and IP port of the remote
machine on which the instance of a Vivado Hardware Server is running.

& XILINX

ALL PROGRAMMABLE. To continue, click Next.

< Back Mext = ] l Cancel

Figure 152: Open Hardware Target

On the Hardware Server Settings page, ensure that the Connect to field is set to Local server
(target is on local machine), as shown in Figure 153.

4. Click Next.

=

¢ Open New Hardware Target
Hardware Server Settings
Select local or remote hardware server, then configure the host name and port settings. Use Local server if ‘
the target is attached to the local machine; otherwise, use Remote server.

Connect to: | Local server (target is on local machine) -

Click Next to launch and/or connect to the hw_server (port 3121) application on the local machine.

Figure 153: Specify Server Name

5. On the Select Hardware Target page, shown below, click Next.
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=

¢ Open New Hardware Target
Select Hardware Target
Select a hardware target from the list of available targets, then set the appropriate JTAG clock (TCK) ‘

frequency. If you do not see the expected devices, decrease the frequency or select a different target.
Hardware Targets

Type Name JTAG Clock Frequency

o yilinx_tcf | Digilent/210203357707A [13000000

Hardware Devices (for unknown devices, specify the Instruction Register (IR) length)
Name ID Code IR Length
& xc7k325t_0 03651093 6

Hardware server: localhost:3121

< Back ” Mext > Finish

Figure 154: Select Hardware Target

6. Ensure that all the settings are correct on the Open Hardware Target Summary dialog box and click
Finish.

=

¢ Open New Hardware Target

Open Hardware Target Summary

VIVADO!

HLx Editions (0 Hardware Server Settings:
o Server: localhost:3121

(D) Target Settings:

o Target: xilinx_tcf/Digilent/210203357707A
o Frequency: 15000000

& XILINX

ALL PROGRAMMABLE. To connect to the hardware described above, click Finish

Next = FEinish ]’ Cancel

Figure 155: Open Hardware Target Summary

Embedded Processor Hardware Design www.xilinx.com | Send Feedback l 118
UG940 (v2016.1) April 6, 2016


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG940&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Embedded%20Processor%20Hardware%20Design&releaseVersion=2016.1&docPage=118

& XILINX

ALL PROGRAMMABLE.

Lab 4: Using the Embedded MicroBlaze Processor

Step 14: Setting the MicroBlaze to Logic Cross Trigger

When the Vivado Hardware Session successfully connects to the ZC702 board, you see the information
shown in Figure 156.

Hardware _ O o =
Q= =|E
Mame Status
=B localhost (1] Connected
—--QG xilinx_tcf/Digilent/2102033... Open
= %c7k325t_0 (3) Programmed
~EE XADC (System Monitor]
hw_ila_1 (ILA] ) Idle
¢ hw_ila_2 (ILA] ) Idle

Figure 156: Vivado Hardware Window

1. Select the ILA - hw_ila_1 tab and set the Trigger Mode Settings as follows:
e Set Trigger mode to TRIG_IN_ONLY
e Set TRIG_OUT mode to TRIG_IN_ONLY
e Under Capture Mode Settings, change Trigger position in window to 512.

Trigger mode: TRIG_IN_OMLY

TRIG OUT mode: | TRIG_IN_OHNLY

Capture Mode Settings
Capture mode: ALWAYS

Number of windows: 1

Window data depth:

Trigger position in window: |512

General Settings

R4 Refresh rate: |500 ms

1024 ~ | [1-

b
Capture status
Window 1 of 1
Idle

Trigger Setup - hw_ila_1

S hw ila 1 x| & hw ila 2 x [
Settings - hw_ila_1 — O % Status - hw_ila_1 - O %
Trigger Mode Settings % Core status

Idle Pre-Trigger ‘Waiting for Trigger Post-Trigger Full

Window sample 0 of 1024  Total sample 0 of 1024
Idle Idle

— o= Capture Setup - hw_ila_1

Embedded Processor Hardware Design
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Figure 157: Set ILA Properties for hw_ila_1
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2. Arm the ILA core by clicking the Run Trigger button Dl

This arms the ILA and you should see the status “Waiting for Trigger” as shown in Figure 158.

Manager - localhost/xlinx_tcf/Digilent/210203357707A X
Hardware —oe x S hw_ila_1 x| & hwila2 x oo =
A= RIDIP Settings - hw_ila_1 —ox Status - hw_ila_1 —ox
(Eeed SRS Trigger Made Settings ; Core status
=+ E localhost (1) Connected ~ .
E B xilinx_tcf/Digilent/2102033... Open Trigger mode: TRIG_IN_ONLY - s Idle Pre-Trigger Waiting for Trigger Post-Trigger Full
S xe7k32580 (3)  Programmed TRIG OUT mode: | TRIG_IN_ONLY - Capture status
REDETE Monitor = Window 1 of 1 Window sample 512 of 1024 Total sample 512 of 1024
2 hwe_ila_2 (1LA) O Idle X AT -l %
Capture Mode Settings
Capture mode: ALWAYS Trigger Setup - hw_ila_1 _ O % || Capture Setup - hw_ila_1 _ox
Number of windows: 1 [1-1024) & LS
Window data depth: 1024 ~ | [1-1024]])| ¥ +
Trigger postion in window: [512 [0-1023| — ecthe o= b be Capture equation cannot be added because
Press the = button to add probes. Ep) 'hw_ila_1' does not support BASIC capture mode.

Figure 158: Armed ILA Core

3. Select the hw_ila_2 tab to set up trigger conditions to capture the trace, and set the Trigger Mode

Settings as follows:

e Set Trigger mode to BASIC_ONLY.

e Under Capture Mode Settings, change Trigger position in window to 512.

e With the hw_ila_2 tab selected, click on the + sign in the Trigger Setup window.

Trigger Setup - hw_ila_2 —

e

+

D
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Press the mbl_lttcl'l to add probes

Figure 159: Add Probes to setup trigger
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4. Selectthemb subsystem i/mdm 1 TRIG OUT 0 TRIG signal from the Debug Probes window
under hw_ila_2 into the Trigger Setup window.

Add Probes b

Search:

= mb_subsystem_ifila_0_TRIG_OUT_ACK
= mb_subsystem_ifila_0_TRIG_OUT_TRIG
= mb_subsystem_i/mdm_1_TRIG_OUT_0_ACK

B mb_subsystem_i/mdm_1_TRIG_OUT_0_TRIG

l 0K ” Cancel l

Figure 160: Add Probes window

5. Click OK.

6. Inthe Trigger Setup window, click the Compare Value field for the
mb_subsystem/mdm 1 TRIG OUT O TRIG signal, ensure that the Radix field is set to B and set
the Value field to 1. This essentially sets up the ILA to trigger when the trig out transitions to a
value of 1.

Trigger Setup - hw_ila_2 S

X name Compare Value

=+ dm_1_TRIG_OUT_0_TRIG| Y3 >

Operator: | == (equal) -
D

Radix: [B] (Binary) -

Value: 1 (logical one) A

Waveform - hw_ila_2 0K ] l Cancel l

s I : -

Figure 161: Set Trigger Condition

7. Click OK.

8. Arm the ILA by clicking the Run Trigger button Pl'in the toolbar of the hw_ila_2 window. Just like
hw_ila_1, this ILA should be "armed” and waiting for the trigger condition to happen.

9. In SDK, in the Debug window, click the MicroBlaze #0 in the Debug window and click the Resume
button | .
Vivado displays the hw_ila_2 trigger as shown in Figure 162.
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hwy_ila_2 —_ O a =
Waveform - hw_ila_2 — X

Figure 162: MicroBlaze to Logic Cross Trigger Waveform

Likewise, hw_ila_1 also triggers as seen in Figure 163.

hw_ila_1 — 0O a =

Waveform - hw_ila_1 g X

m

Figure 163: MicroBlaze to Logic Cross Trigger Waveform in hw_ila_1

This demonstrates that when the breakpoint is encountered during code execution, the MicroBlaze
triggers the ILA that is set up to trigger. Between the two waveform windows, you can monitor the state
of the hardware at a certain point of code execution.
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Step 15: Setting the Logic to Processor Cross-Trigger

Now try the logic to processor side of the cross-trigger mechanism. In other words, remove the
breakpoint that you set earlier on line 50 to have the ILA trigger the processor and stop code execution.
To do this:

1.

Select the Breakpoints tab towards the top right corner of SDK window, and uncheck the
testperiph.c [line: 50] checkbox. This removes the breakpoint that you set up earlier.

Note: Alternatively, you can also click on the breakpoint in the testperiph.c file and select Disable
Breakpoint.

In the Debug window, right-click the MicroBlaze #0 target and select Resume. The code runs
continuously because it has an infinite loop.

You can see the code executing in the Terminal Window in SDK.

In Vivado, select the hw_ila_1 tab. Change the Trigger Mode to BASIC_OR_TRIG_IN and the
TRIG_OUT mode to TRIGGER_OR_TRIG_IN.

Select the hw_ila_2 tab, and delete the existing probe in the Basic Trigger Setup window by selecting
it and clicking the Remove Selected Probe "-* button to the left.

Click on the + sign in the Trigger Setup window to add the
mb_subsystem i/ila 0 TRIG_OUT TRIG signal from the Add Probes window.

In the Basic Trigger Setup window, click the Compare Value column for the

mb subsystem i/ila 0 TRIG OUT TRIG signal, ensure that the Radix field is set to [B]
(Binary) and set the Value field to 1. This essentially sets up the ILA to trigger when the trig_out
transitions to a value of 1.

Click OK.

Click the Run Trigger button Pl to “arm” the ILA. It moves into the "“Waiting for Trigger”
condition.

Select the hw_ila_1 tab again and click the Run Trigger Immediate button W This triggers the
hw_ila_2 and the waveform window looks like Figure 164.
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hw_ila_2 —Oa =
Waveform - hw_ila_2 — X

Figure 164: Waveform Demonstrating PS to PL Trigger

This also stops the Processor from executing code because the ILA triggers the TRIG OUT port,
which interrupts the processor. This is seen in SDK the in the highlighted area of the debug window.

¥* Debug =2 ® T = O
4 ¥ peri_test Debug (Local)
4 [ xc7k325t
4 7% Debug Module at USER2
4 ® MicroBlaze #0 (Suspended)
0x8000054¢ GpioOutputExample(): ./src/xgpio_tapp_example.c, line 226
(0x800003b4 main(): ../src/testperiph.c, line 47
0x80000324 _crtinit()
0x80000024 _start1()

Figure 165: Verify that the Processor Has Been Interrupted in SDK

Conclusion

In this tutorial, you:
e Stitched together a design in the Vivado IP integrator tool
e Brought the design through implementation and bitstream generation
e Exported the hardware to SDK
e Created and modified application code that runs on a Standalone Operating System
e Modified the linker script so that the code executes from the DDR3

e Verified cross-trigger functionality between the MicroBlaze processor executing code and the
design logic
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Lab Files

The Tcl script 1ab4. tcl is included with the design files to perform all the tasks in Vivado. You will also
need the system.xdc file to run in Tcl mode. The SDK operations must be done in the SDK GUL You
might need to modify the Tcl script to match the project path and project name on your machine.
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Please Read: Important Legal Notices

The information disclosed to you hereunder (the “Materials”) is provided solely for the selection and use of Xilinx products. To the maximum
extent permitted by applicable law: (1) Materials are made available "AS IS" and with all faults, Xilinx hereby DISCLAIMS ALL WARRANTIES
AND CONDITIONS, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY,
NON-INFRINGEMENT, OR FITNESS FOR ANY PARTICULAR PURPOSE; and (2) Xilinx shall not be liable (whether in contract or tort,
including negligence, or under any other theory of liability) for any loss or damage of any kind or nature related to, arising under, or in
connection with, the Materials (including your use of the Materials), including for any direct, indirect, special, incidental, or consequential loss
or damage (including loss of data, profits, goodwill, or any type of loss or damage suffered as a result of any action brought by a third party)
even if such damage or loss was reasonably foreseeable or Xilinx had been advised of the possibility of the same. Xilinx assumes no
obligation to correct any errors contained in the Materials or to notify you of updates to the Materials or to product specifications. You may not
reproduce, modify, distribute, or publicly display the Materials without prior written consent. Certain products are subject to the terms and
conditions of Xilinx’s limited warranty, please refer to Xilinx's Terms of Sale which can be viewed at http://www.xilinx.com/legal.htm#tos; IP
cores may be subject to warranty and support terms contained in a license issued to you by Xilinx. Xilinx products are not designed or
intended to be fail-safe or for use in any application requiring fail-safe performance; you assume sole risk and liability for use of Xilinx products
in such critical applications, please refer to Xilinx’s Terms of Sale which can be viewed at http://www.xilinx.com/legal.htm#tos.

© Copyright 2013 — 2016 Xilinx, Inc. Xilinx, the Xilinx logo, Artix, ISE, Kintex, Spartan, Virtex, Zyng, and other designated brands included
herein are trademarks of Xilinx in the United States and other countries. All other trademarks are the property of their respective owners.
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